From 2fa0cf9ab3e706a25ceea821c421668e92100ada Mon Sep 17 00:00:00 2001
From: Fabian Affolter <fabian@affolter-engineering.ch>
Date: Wed, 30 Oct 2013 10:12:02 +0000
Subject: [PATCH] main/abiword: specify license

---
 main/abiword/APKBUILD | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

diff --git a/main/abiword/APKBUILD b/main/abiword/APKBUILD
index c647e33c9c7a..3d88a108cfc1 100644
--- a/main/abiword/APKBUILD
+++ b/main/abiword/APKBUILD
@@ -1,11 +1,11 @@
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=abiword
 pkgver=3.0.0
-pkgrel=0
+pkgrel=1
 pkgdesc="A fully-featured word processor"
 url="http://www.abisource.com"
 arch="all"
-license="GPL"
+license="GPL2+"
 makedepends="gtk+3.0-dev libgsf-dev enchant-dev fribidi-dev wv-dev
 	popt-dev libjpeg-turbo-dev librsvg-dev bzip2-dev goffice-dev pcre-dev
 	libxslt-dev"
@@ -16,7 +16,6 @@ makedepends="$makedepends boost-dev"
 # collab plugin
 makedepends="$makedepends gnutls-dev libsoup-dev dbus-glib-dev"
 
-
 subpackages="$pkgname-dev $pkgname-doc $pkgname-plugins"
 
 _plugins="applix babelfish bmp clarisworks collab docbook eml epub
@@ -32,8 +31,9 @@ done
 source="http://www.abisource.com/downloads/$pkgname/$pkgver/source/$pkgname-$pkgver.tar.gz
 	"
 
+_builddir="$srcdir"/$pkgname-$pkgver
 prepare() {
-	cd "$srcdir"/$pkgname-$pkgver
+	cd "$_builddir"
 	for i in $source; do
 		case $i in
 		*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
@@ -42,7 +42,7 @@ prepare() {
 }
 
 build() {
-	cd "$srcdir"/$pkgname-$pkgver
+	cd "$_builddir"
 	./configure \
 		--build=$CBUILD \
 		--host=$CHOST \
@@ -56,7 +56,7 @@ build() {
 
 #	="opendocument goffice latex" \
 package() {
-	cd "$srcdir"/$pkgname-$pkgver
+	cd "$_builddir"
 	make DESTDIR="$pkgdir" install || return 1
 	rm "$pkgdir"/usr/lib/abiword*/plugins/*.la \
 		"$pkgdir"/usr/lib/*.la || return 1
-- 
GitLab