diff --git a/main/alpine-conf/APKBUILD b/main/alpine-conf/APKBUILD
index f5b6a72c0a66ccdab32f48839c0b18f3a352f5f7..18ae129ee5b97dd37023953963ed8078af84668d 100644
--- a/main/alpine-conf/APKBUILD
+++ b/main/alpine-conf/APKBUILD
@@ -1,13 +1,14 @@
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=alpine-conf
 pkgver=3.8.0
-pkgrel=0
+pkgrel=1
 pkgdesc="Alpine configuration management scripts"
 url=http://git.alpinelinux.org/cgit/$pkgname
 arch="all"
 license="MIT"
 depends="openrc>=0.24.1-r6 busybox>=1.26.1-r3"
 source="https://dev.alpinelinux.org/archive/alpine-conf/alpine-conf-$pkgver.tar.xz
+	grub.patch
 	"
 
 builddir="$srcdir"/$pkgname-$pkgver
@@ -24,4 +25,5 @@ package() {
 	done
 }
 
-sha512sums="402d01dbc2b2aa987658f689e8a88feda6a633a393e746d2db3ee108274ff20be21f292406fa4aad543a665edfaff342795deb2c59cbc8c2ff8577f8f7c2485d  alpine-conf-3.8.0.tar.xz"
+sha512sums="402d01dbc2b2aa987658f689e8a88feda6a633a393e746d2db3ee108274ff20be21f292406fa4aad543a665edfaff342795deb2c59cbc8c2ff8577f8f7c2485d  alpine-conf-3.8.0.tar.xz
+d1080c84499bcf2f14131899aa57680b64cfe256d390faf5ce1ad1d2a32768ba32a721b0177962b74eb9887e555ceeb9197022a33bac7b3ecc8eca1ffea9c2f4  grub.patch"
diff --git a/main/alpine-conf/grub.patch b/main/alpine-conf/grub.patch
new file mode 100644
index 0000000000000000000000000000000000000000..d5d22a2ffd4b728f15b5c78b39b7f93632f28c42
--- /dev/null
+++ b/main/alpine-conf/grub.patch
@@ -0,0 +1,29 @@
+diff --git a/setup-disk.in b/setup-disk.in
+index 4ed0cbd..5eb8638 100644
+--- a/setup-disk.in
++++ b/setup-disk.in
+@@ -306,16 +306,14 @@ setup_grub() {
+ 		esac
+ 	fi
+ 
+-	# setup GRUB config
+-
+-	# all_video is needed to remove the video error on boot
+-	cat > "$mnt"/boot/grub/grub.cfg <<- EOF
+-	set timeout=2
+-	insmod all_video
+-	menuentry "Alpine Linux" {
+-	    linux   /boot/vmlinuz-$KERNEL_FLAVOR modules=$modules root=$root $kernel_opts
+-	    initrd  /boot/initramfs-$KERNEL_FLAVOR
+-	}
++	# setup GRUB config. trigger will generate final grub.cfg
++	install -d "$mnt"/etc/default/
++	cat > "$mnt"/etc/default/grub <<- EOF
++	GRUB_DISTRIBUTOR="Alpine"
++	GRUB_TIMEOUT=2
++	GRUB_DISABLE_SUBMENU=y
++	GRUB_DISABLE_RECOVERY=true
++	GRUB_CMDLINE_LINUX_DEFAULT="modules=$modules $kernel_opts"
+ 	EOF
+ }
+