Commit a1075bfb authored by prspkt's avatar prspkt Committed by Leo
Browse files

main/putty: upgrade to 0.75

 - ppc64 patch is now upstream, remove.
parent 83a5d94d
Pipeline #81476 canceled with stages
in 8 seconds
# Maintainer: Jeff Bilyk <jbilyk@alpinelinux.org>
pkgname=putty
pkgver=0.74
pkgver=0.75
pkgrel=0
pkgdesc="SSH and telnet client"
url="https://www.chiark.greenend.org.uk/~sgtatham/putty/"
......@@ -9,8 +9,7 @@ license="MIT"
depends="ncurses-terminfo-base"
makedepends="linux-headers"
subpackages="$pkgname-doc"
source="http://the.earth.li/~sgtatham/putty/$pkgver/putty-$pkgver.tar.gz
fix-ppc64le-disable-werror.patch"
source="http://the.earth.li/~sgtatham/putty/$pkgver/putty-$pkgver.tar.gz"
options="!check" # no test suite
# secfixes:
......@@ -37,5 +36,6 @@ package() {
make DESTDIR="$pkgdir" install
}
sha512sums="0da86849ea764cd88643bd2c1984ac7211ae72dd7c41232307b1960a29ca9518044b022d87c60272d6db71a3357026862a112bedb90ee732b41494fca3acde9b putty-0.74.tar.gz
b10b2332ca0592db5664311d1bba7549ded79f16f6eef13dab3caca21626d97657f31e8603766e00b1a06f42cf229107eb53929730fe48e97cfc9216093fcc4c fix-ppc64le-disable-werror.patch"
sha512sums="
3dbc15485008a98daf60236061253e66b94a6e5da123fc84c5f0ac006c84e17c70fe748987677775e3b54a12297eb826cccf70a4fc039b633bc2d512938b3028 putty-0.75.tar.gz
"
diff --git a/configure b/configure
index d68c382..5db360e 100755
--- a/configure
+++ b/configure
@@ -5995,7 +5995,7 @@ fi
if test "x$GCC" = "xyes"; then
:
- WARNINGOPTS='-Wall -Werror -Wpointer-arith -Wvla'
+ WARNINGOPTS='-Wall -Wpointer-arith -Wvla'
else
:
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment