From ef25c6cf41970368cce00be35fb5f715086b2c94 Mon Sep 17 00:00:00 2001
From: Natanael Copa <ncopa@alpinelinux.org>
Date: Thu, 14 Feb 2013 10:46:18 +0100
Subject: [PATCH] abump: add option -f to set "fixes" in commit message

---
 abump.in | 16 ++++++++++++----
 1 file changed, 12 insertions(+), 4 deletions(-)

diff --git a/abump.in b/abump.in
index 9d310a396507..10ebb8b61dff 100755
--- a/abump.in
+++ b/abump.in
@@ -26,10 +26,16 @@ do_bump() {
 	fi
 
 	msg="$section/$pkgname: $upgrade to ${pkgver}${cve}"
+	if [ -n "$fixes" ]; then
+		msg="$msg
+
+fixes #${fixes#\#}
+"
+	fi
 	echo "$msg"
-	
+
 	( . ./APKBUILD; type package | grep -q function ) || die "package() missing"
-		
+
 	sed -i -e "s/^pkgver=.*/pkgver=$pkgver/" \
 		-e "s/^pkgrel=.*/pkgrel=0/" \
 		APKBUILD
@@ -42,19 +48,21 @@ do_bump() {
 
 usage() {
 	echo "$program - utility to bump pkgver in APKBUILDs"
-	echo "usage: $program [-hR] [-s CVE-1,CVE-2,...]"
+	echo "usage: $program [-hR] [-s CVE-1,CVE-2,...] [-f ISSUE]"
 	echo ""
 	echo "  -h  show this help"
 	echo "  -R  run abuild with -R for recursive building"
 	echo "  -k  keep existing packages"
 	echo "  -s  security update"
+	echo "  -f  fixes ISSUE"
 	exit 0
 }
 
 keep=
 recursive="-r"
-while getopts "hkRs:" opt; do
+while getopts "f:hkRs:" opt; do
 	case $opt in
+	f) fixes="${OPTARG}";;
 	h) usage;;
 	k) keep="-k";;
 	R) recursive="-R";;
-- 
GitLab