diff --git a/abuild-sudo.c b/abuild-sudo.c
index 66f212a86c9affc705f579b2803d401e55bef929..2f34f3d25c54daa4ca31072c2d52e2b6bac05eee 100644
--- a/abuild-sudo.c
+++ b/abuild-sudo.c
@@ -1,3 +1,12 @@
+/* abuild-sudo.c - limited root privileges for users in "abuild" group
+ *
+ * Copyright (C) 2012 Natanael Copa <ncopa@alpinelinux.org>
+ * All rights reserved.
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation. See http://www.gnu.org/ for details.
+ */
 
 #include <sys/types.h>
 
diff --git a/abump.in b/abump.in
index 10ebb8b61dff5f3834efea1c9a7ae65c5e4314c3..897b50e74fa9ca950db6f9347c7b3b54ffb4d1ec 100755
--- a/abump.in
+++ b/abump.in
@@ -1,5 +1,11 @@
 #!/bin/sh
 
+# abump - bump pkgver in APKBUILDs
+# Copyright (c) 2012 Natanael Copa <ncopa@alpinelinux.org>
+#
+# Distributed under GPL-2
+#
+
 program=${0##*/}
 
 die() {
diff --git a/apkgrel.in b/apkgrel.in
index f319a831456313b9d189374ede9d6e14b729b86e..3feb4f309e77409db8cf1b0cdbad56fd31953bb1 100644
--- a/apkgrel.in
+++ b/apkgrel.in
@@ -1,5 +1,11 @@
 #!/bin/sh
 
+# apkgrel - display or bump pkgrel in APKBUILDs
+# Copyright (c) 2012 Natanael Copa <ncopa@alpinelinux.org>
+#
+# Distributed under GPL-2
+#
+
 program=${0##*/}
 
 do_show() {
diff --git a/checkapk.in b/checkapk.in
index 76d63eb8e0f6d5c75e6aab154b490485fbf9fb8c..9c1d9fd927ea155e0613d4ba39453af9d6d372fc 100644
--- a/checkapk.in
+++ b/checkapk.in
@@ -1,5 +1,11 @@
 #!/bin/sh
 
+# checkapk - find ABI breakages in package upgrades
+# Copyright (c) 2012 Natanael Copa <natanael.copa@gmail.com>
+#
+# Distributed under GPL-2
+#
+
 die() {
 	echo "$@" >&2
 	exit 1