From d3b36e1cf2b9ee8b1210b1ac9f236b165f65cb81 Mon Sep 17 00:00:00 2001
From: Natanael Copa <ncopa@alpinelinux.org>
Date: Wed, 3 Jun 2009 11:43:58 +0000
Subject: [PATCH] alpine.mk: configureable free space on usb image

use USBIMG_FREE to set how many kB you want to have as free space on
usb image.
---
 alpine.mk | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/alpine.mk b/alpine.mk
index 46a71e57871a..65f41f98892a 100755
--- a/alpine.mk
+++ b/alpine.mk
@@ -229,7 +229,8 @@ $(ISO_SHA1):	$(ISO)
 # USB image
 #
 USBIMG 		:= $(ALPINE_NAME)-$(ALPINE_RELEASE)-$(ALPINE_ARCH).img
-USBIMG_SIZE 	= $(shell echo $$(( `du -s $(ISO_DIR) | awk '{print $$1}'` + 8192 )) )
+USBIMG_FREE	?= 8192
+USBIMG_SIZE 	= $(shell echo $$(( `du -s $(ISO_DIR) | awk '{print $$1}'` + $(USBIMG_FREE) )) )
 MBRPATH 	:= /usr/share/syslinux/mbr.bin
 # the offset where the frist partition is found
 USBIMG_OFFSET	:= 16384
-- 
GitLab