diff --git a/extra/lpc/APKBUILD b/extra/lpc/APKBUILD
new file mode 100644
index 0000000000000000000000000000000000000000..af2b8a089d0b1f99c3c66ede21372ca82e2e65d8
--- /dev/null
+++ b/extra/lpc/APKBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lpc
+pkgver=1.0.0
+pkgrel=0
+pkgdesc="Lua Process Call"
+url="http://lua.net-core.org/sputnik.lua?p=Telesto:About"
+license="MIT/X11"
+depends="uclibc lua-dev"
+source="http://lua.net-core.org/dl/telesto/lpc-$pkgver.tar.gz"
+
+build() {
+	cd "$srcdir/$pkgname-$pkgver"
+	make CFLAGS="$CFLAGS" LDFLAGS="$LDFLAGS -shared"
+	# does not respect DESTDIR
+	make install PREFIX="$pkgdir"/usr
+}
+
+md5sums="fce047808fbdfe3f9439557c7afae871  lpc-1.0.0.tar.gz"