From b0b66ea098a52e284bd3c90d68332c4ee068d565 Mon Sep 17 00:00:00 2001
From: Natanael Copa <ncopa@alpinelinux.org>
Date: Tue, 28 Jun 2011 07:11:02 +0000
Subject: [PATCH] newapkbuild: rename config_* functions to build_*

We call make as well as needed so build_* is better function name.
---
 newapkbuild.in | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

diff --git a/newapkbuild.in b/newapkbuild.in
index 110b47d18386..b271049a4343 100755
--- a/newapkbuild.in
+++ b/newapkbuild.in
@@ -33,7 +33,7 @@ is_url() {
 }
 
 # Build sections
-config_autotools() {
+build_autotools() {
 	cat >>APKBUILD<<__EOF__
 	./configure --prefix=/usr \\
 		--sysconfdir=/etc \\
@@ -45,14 +45,14 @@ config_autotools() {
 __EOF__
 }
 
-config_perl() {
+build_perl() {
 	cat >>APKBUILD<<__EOF__
 	PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
 	make || return 1
 __EOF__
 }
 
-config_python() {
+build_python() {
 	cat >>APKBUILD<<__EOF__
 	python setup.py build || return 1
 __EOF__
@@ -210,11 +210,11 @@ __EOF__
 
 	case "$buildtype" in
 	autotools)
-		config_autotools;;
+		build_autotools;;
 	perl)
-		config_perl;;
+		build_perl;;
 	python)
-		config_python;;
+		build_python;;
 	esac
 
 	cat >>APKBUILD<<__EOF__
-- 
GitLab