diff --git a/buildrepo b/buildrepo
index 067629dfbbff4f1d4e160c981bbbc67b5b768c4e..42e055942f95d2eb201d8c379cd5e9ea17986d3f 100755
--- a/buildrepo
+++ b/buildrepo
@@ -43,8 +43,6 @@ build() {
 
 	for i in */APKBUILD; do
 		( cd ${i%/*} || return 1
-		build $1 || exit 1
-		purge $1 || exit 1
 		  PKGDEST="$repodir/$repo" abuild -r || return 1
 		) || return 1
 	done