diff --git a/Makefile b/Makefile
index b284d47597185a32d542e3c23b8e08174caac054..7d7099c6059e4c52a733b0f2ce6ac3e4cbdf3918 100644
--- a/Makefile
+++ b/Makefile
@@ -2,9 +2,10 @@
 PACKAGE		:= abuild
 VERSION		:= 1.14
 
-prefix ?= /usr
-sysconfdir ?= /etc
-datadir ?= $(prefix)/share/$(PACKAGE)
+prefix		?= /usr
+sysconfdir	?= /etc
+datadir		?= $(prefix)/share/$(PACKAGE)
+apkcache	?= /var/cache/abuild/apks
 
 USR_BIN_FILES	:= abuild devbuild mkalpine buildrepo
 SAMPLES		:= sample.APKBUILD sample.initd sample.confd \
@@ -29,7 +30,8 @@ TAR		:= tar
 SED_REPLACE	:= -e 's:@VERSION@:$(FULL_VERSION):g' \
 			-e 's:@prefix@:$(prefix):g' \
 			-e 's:@sysconfdir@:$(sysconfdir):g' \
-			-e 's:@datadir@:$(datadir):g'
+			-e 's:@datadir@:$(datadir):g' \
+			-e 's:@apkcache@:$(apkcache):g'
 
 .SUFFIXES:	.sh.in .in
 .sh.in.sh:
diff --git a/abuild.in b/abuild.in
index 6286d39af3760c8c672bc3f6bad91985094c7ac4..d1255b6119a34d7864022ce26e3678db59fbf177 100755
--- a/abuild.in
+++ b/abuild.in
@@ -10,6 +10,7 @@
 
 abuild_ver=@VERSION@
 sysconfdir=@sysconfdir@
+abuildrepo=@apkcache@
 
 startdir="$PWD"
 srcdir=${srcdir:-"$startdir/src"}
@@ -17,7 +18,6 @@ pkgbasedir=${pkgbasedir:-"$startdir/pkg"}
 pkgrel=0
 repo=${startdir%/*}
 repo=${repo##*/}
-abuildrepo=/var/cache/abuild/apks
 
 # defaults
 SRCDEST=${SRCDEST:-$startdir}