diff --git a/main/musl/APKBUILD b/main/musl/APKBUILD
index ffbc6d4140086a05cb8448be327d1f6a75b39604..ded6dd6ee56a2b4809d24d5962be4d7e2a5c1667 100644
--- a/main/musl/APKBUILD
+++ b/main/musl/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Timo Teräs <timo.teras@iki.fi>
 pkgname=musl
 pkgver=0.9.14
-pkgrel=1
+pkgrel=2
 pkgdesc="the musl c library (libc) implementation"
 url="http://www.musl-libc.org/"
 arch="all"
@@ -14,6 +14,7 @@ install=""
 subpackages="$pkgname-dev $pkgname-utils"
 [ "${CTARGET#*musl}" = "$CTARGET" ] && subpackages="$subpackages musl-gcc:crosstool"
 source="http://www.musl-libc.org/releases/musl-$pkgver.tar.gz
+	add-missing-i386-syscall-numbers.patch
 	add-rfc3678-mcast-structs.patch
 	workaround-gcc-pr58245.patch
 	getopt_long.c
@@ -34,6 +35,9 @@ prepare() {
 	# use GNU compatible getopt() from BSD
 	rm -f src/misc/getopt*.c
 	cp "$srcdir"/getopt_long.c src/misc/
+
+	# remove libintl wrappers that we don't want
+	rm src/locale/intl.c include/libintl.h
 }
 
 install_sysroot_headers() {
@@ -101,18 +105,21 @@ crosstool() {
 }
 
 md5sums="bfb685695aa942e64c63170589e575b2  musl-0.9.14.tar.gz
+f116cf69bcbcb7080ef3aa521acce8b8  add-missing-i386-syscall-numbers.patch
 dcdded62320e3aa2a550058a75bc9c6e  add-rfc3678-mcast-structs.patch
 7a09c5cd7b3e9532e6902f54a5e928bb  workaround-gcc-pr58245.patch
 61c6c1e84ed1df82abbe6d75e90cf21c  getopt_long.c
 0df687757221bbb0fc1aa67f1bd646f9  __stack_chk_fail_local.c
 ef81489a6258501cf45db58dfc6d5211  getent"
 sha256sums="982e9de1287cf95f9aa526adba008660d8885bfccc41faf5c613ea47f1922872  musl-0.9.14.tar.gz
+84886493008bdca79ad223708e5568baeb948a520499b9f4eea2f1526aefb304  add-missing-i386-syscall-numbers.patch
 6e8c4fe897c88e4b8f5654766cdaa5d14a0bfa51f28518b53cba2628ca700cdb  add-rfc3678-mcast-structs.patch
 45d6efda7450809e4e68f6e951431dcadf6cb7f0260930d50a9f1a8667aca49f  workaround-gcc-pr58245.patch
 d9b644ec20bc33e81a7c52b9fcf7973d835923a69faf50f03db45534b811bd96  getopt_long.c
 299a7d75a09de3e2e11e7fb4acc3182e4a14e868093d2f30938fce9bfcff13da  __stack_chk_fail_local.c
 d6996273f5aaaed429058257e4646b243d9e3a4d8609522f802762453f5be4cb  getent"
 sha512sums="e5c3f7b1549dc2f9cbd3359cc413f761d5967607c23705f651c33d0ae93f00582193a41fe1f87158467d58d8eba2d7c09e0fe2f2b2c02c1dda78eee1a4cecff6  musl-0.9.14.tar.gz
+e6cdb6b4c87e2488d31ac46898010dc9d41f31f2ed9c6f2f8a763b76e63587a37a54a7557cd7db1c524b1fcbd17e5418ec1058b30dc17cc91c3fb3ac7cd47fc8  add-missing-i386-syscall-numbers.patch
 72789ddf7018bb0878cb1f9c8a47d7b371a9a3e1c58693090d518bf1cc0d26e4edda3e3a405b2ddcdfb06f05a94eb4a358d9e26f742702be891a6578673a0369  add-rfc3678-mcast-structs.patch
 69ad3fc851b44f33dd7c98b83fd0adbd149b37263d17b989f4d7338ee0703dfe8994f4299744e2509492300227d652de6f21b6cdba9b633fcefd3d9f7ca0cf20  workaround-gcc-pr58245.patch
 140f3f20d30bd95ebce8c41b8cc7f616c6cbedf4ea06c729c21014e74f6043796825cc40ebc5180620ea38173afdba23f09ebf6d8b11fa05440b14d23764fca9  getopt_long.c
diff --git a/main/musl/add-missing-i386-syscall-numbers.patch b/main/musl/add-missing-i386-syscall-numbers.patch
new file mode 100644
index 0000000000000000000000000000000000000000..8c0b0a892d6071cdcf43e061562306646c24bc5b
--- /dev/null
+++ b/main/musl/add-missing-i386-syscall-numbers.patch
@@ -0,0 +1,41 @@
+From 78178542e73e143bf44b3ba32cf0b58ced53f2d5 Mon Sep 17 00:00:00 2001
+From: Rich Felker <dalias@aerifal.cx>
+Date: Thu, 26 Sep 2013 14:17:36 -0400
+Subject: [PATCH] add missing i386 syscall numbers
+
+somehow the range 335-339 was missed when updating the file.
+---
+ arch/i386/bits/syscall.h | 10 ++++++++++
+ 1 file changed, 10 insertions(+)
+
+diff --git a/arch/i386/bits/syscall.h b/arch/i386/bits/syscall.h
+index 800409a..2af242b 100644
+--- a/arch/i386/bits/syscall.h
++++ b/arch/i386/bits/syscall.h
+@@ -333,6 +333,11 @@
+ #define __NR_inotify_init1	332
+ #define __NR_preadv		333
+ #define __NR_pwritev		334
++#define __NR_rt_tgsigqueueinfo	335
++#define __NR_perf_event_open	336
++#define __NR_recvmmsg		337
++#define __NR_fanotify_init	338
++#define __NR_fanotify_mark	339
+ #define __NR_prlimit64		340
+ #define __NR_name_to_handle_at	341
+ #define __NR_open_by_handle_at	342
+@@ -683,6 +688,11 @@
+ #define SYS_inotify_init1	332
+ #define SYS_preadv		333
+ #define SYS_pwritev		334
++#define SYS_rt_tgsigqueueinfo	335
++#define SYS_perf_event_open	336
++#define SYS_recvmmsg		337
++#define SYS_fanotify_init	338
++#define SYS_fanotify_mark	339
+ #define SYS_prlimit64		340
+ #define SYS_name_to_handle_at	341
+ #define SYS_open_by_handle_at	342
+-- 
+1.8.4
+