From 73918f526c1ccfda7b0a078c16b912a94658a2b2 Mon Sep 17 00:00:00 2001
From: Natanael Copa <ncopa@alpinelinux.org>
Date: Fri, 22 Feb 2013 09:53:55 +0000
Subject: [PATCH] buildrepo: only consider rebuilding packages that has proper
 arch set

---
 buildrepo.in | 15 +++++++++++++++
 1 file changed, 15 insertions(+)

diff --git a/buildrepo.in b/buildrepo.in
index 1f218cc21d89..da4e91b1120c 100755
--- a/buildrepo.in
+++ b/buildrepo.in
@@ -47,6 +47,16 @@ all_exist() {
 	return 0
 }
 
+is_in() {
+	local needle="$1"
+	shift
+	while [ $# -gt 0 ]; do
+		[ "$needle" = "$1" ] && return 0
+		shift
+	done
+	return 1
+}
+
 list_needbuild() {
 	local repo="$1" i=
 
@@ -63,8 +73,13 @@ list_needbuild() {
 		pkgver=
 		pkgrel=
 		subpackages=
+		arch=
 		. ./APKBUILD
 
+		if ! is_in all $arch && ! is_in $CARCH $arch; then
+			continue
+		fi
+
 		pkgs=
 		for subpkg in $pkgname $subpackages; do
 			pkgfile=${subpkg%:*}-$pkgver-r$pkgrel.apk
-- 
GitLab