From 6a0445f7d272e32ae69327d6f0f8a907a657a960 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
Date: Mon, 23 Sep 2013 13:24:28 +0000
Subject: [PATCH] main/musl: fix crosscompiler bootstrap, explicitly specify
 prefix

Since we don't run ./configure, the prefix needs to be explicitly passed
to make. Affects only crosscompiler creation (so no pkgrel bump).
---
 main/musl/APKBUILD | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/main/musl/APKBUILD b/main/musl/APKBUILD
index beec7fe3828c..d12b10c58a2b 100644
--- a/main/musl/APKBUILD
+++ b/main/musl/APKBUILD
@@ -45,7 +45,7 @@ install_sysroot_headers() {
 	x86) ARCH="i386" ;;
 	x86_64) ARCH="x86_64" ;;
 	esac
-	make ARCH="$ARCH" DESTDIR="${CBUILDROOT}" install-headers || return 1
+	make ARCH="$ARCH" prefix=/usr DESTDIR="${CBUILDROOT}" install-headers || return 1
 }
 
 build() {
-- 
GitLab