diff --git a/abuild.in b/abuild.in
index c7772b6e09e19b5b30096cfe28bf762b6a9b2e0c..51018e8ceac0a4ea911a9c7c1b1355490ec29f5c 100755
--- a/abuild.in
+++ b/abuild.in
@@ -957,6 +957,7 @@ usage() {
 	echo "Options:"
 	echo " -d  Disable dependency checking"
 	echo " -f  Force specified cmd, even if they are already done"
+	echo " -F  Force run as root"
 	echo " -h  Show this help"
 	echo " -i  Install PKG after successul build"
 	echo " -k  Keep built packages, even if APKBUILD or sources are newer"
@@ -993,10 +994,11 @@ usage() {
 APKBUILD="${APKBUILD:-./APKBUILD}"
 unset force
 unset recursive
-while getopts "dfhi:kinp:P:qrRs:u" opt; do
+while getopts "dfFhi:kinp:P:qrRs:u" opt; do
 	case $opt in
 		'd') nodeps=1;;
 		'f') force=1;;
+		'F') forceroot=1;;
 		'h') usage;;
 		'i') install_after="$install_after $OPTARG";;
 		'k') keep=1;;
@@ -1013,6 +1015,13 @@ while getopts "dfhi:kinp:P:qrRs:u" opt; do
 done
 shift $(( $OPTIND - 1 ))
 
+# check so we are not root
+if [ "$(whoami)" = "root" ] && [ -z "$FAKEROOTKEY" ]; then
+	[ -z "$forceroot" ] && die "Do not run abuild as root"
+	SUDO=
+	FAKEROOT=
+fi
+
 # find startdir
 [ -f "$APKBUILD" ] || die "Could not find $APKBUILD (PWD=$PWD)"
 APKBUILD=$(readlink -f "$APKBUILD")