From 5cde86ff2925c102d1655550c156f1619deca6e8 Mon Sep 17 00:00:00 2001
From: Natanael Copa <ncopa@alpinelinux.org>
Date: Tue, 2 Nov 2010 09:03:20 +0000
Subject: [PATCH] buildrepo: do not error if there are no packages in repo

---
 buildrepo.in | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/buildrepo.in b/buildrepo.in
index c211789714b4..961d245e8a19 100755
--- a/buildrepo.in
+++ b/buildrepo.in
@@ -39,12 +39,13 @@ all_exist() {
 build() {
 	local repo="$1" i needbuild
 
-	cd "$aportsdir/$repo" || return 1
+	cd "$aportsdir/$repo" || return 0
 
 	# first we try copy everything possible and find out which we need
 	# to rebuild. By doing this we might save us for rebuilding 
 	# needed when running 'abuild -R'
 	for i in */APKBUILD; do
+		[ -f "$i" ] || continue
 		export REPODEST="$repodir"
 		cd "$aportsdir/$repo"/${i%/*} || return 1
 		if abuild -k -q up2date 2>/dev/null; then
-- 
GitLab