diff --git a/apkgrel.in b/apkgrel.in
index 28978e36badf17e0f753029ad8b662922043e42d..645637d501be4ebeb9d5734591641f1649d6db32 100644
--- a/apkgrel.in
+++ b/apkgrel.in
@@ -16,8 +16,24 @@ fi
 . "$datadir/functions.sh"
 
 
+show_plain() {
+	# we source the APKBUILD and show last pkgrel that's read
+	# if this script is invoked with --force, this needn't pass "do_verify"
+	( . "$1" && echo "$pkgrel" )
+}
+
+show_pretty() {
+	(
+	. "$1" || exit 1
+	[ -n "$pkgname" ] || die "$1: no pkgname"
+	printf '%s: r%s\n' "$pkgname" "${pkgrel:-?}"
+	)
+}
+
 do_show() {
-	awk -F= '$1 == "pkgrel" { print $2 }' "$@"
+	local f=
+	# show_pretty is more informative, but would change the output format of this script
+	for f; do show_plain "$f"; done
 }
 
 do_set() {
@@ -32,7 +48,7 @@ do_add () {
 			&& [ -n "$(git diff --name-only $f)" ] \
 			&& continue
 		[ -d "$f" ] && f="$f/APKBUILD"
-		old=$(do_show "$f")
+		old=$(show_plain "$f")
 		setto=$(($old + 1))
 		do_set "$f" || return 1
 	done