From 5847b5473b251ca2af922a8059288c3e0ed0c952 Mon Sep 17 00:00:00 2001
From: Natanael Copa <ncopa@alpinelinux.org>
Date: Wed, 30 Dec 2009 08:51:38 +0000
Subject: [PATCH] sample: use separate package()

---
 sample.APKBUILD | 18 ++++++++++++++----
 1 file changed, 14 insertions(+), 4 deletions(-)

diff --git a/sample.APKBUILD b/sample.APKBUILD
index 5206946e2ab5..17549730ac51 100644
--- a/sample.APKBUILD
+++ b/sample.APKBUILD
@@ -11,8 +11,8 @@ pkgrel=0
 pkgdesc=""
 url=""
 license="GPL"
-depends=""
-makedepends=""
+depends=
+makedepends=
 install=
 subpackages="$pkgname-dev $pkgname-doc"
 source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
@@ -21,14 +21,24 @@ source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
 # remove if not used.
 # depends_dev="somepackage-dev"
 
-build() {
-	cd "$srcdir"/$pkgname-$pkgver
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+	cd "$_builddir"
+	# apply patches here
+}
 
+build() {
+	cd "$_builddir"
 	./configure --prefix=/usr \
 		--sysconfdir=/etc \
 		--mandir=/usr/share/man \
 		--infodir=/usr/share/info
 	make || return 1
+}
+
+package() {
+	cd "$_builddir"
 	make DESTDIR="$pkgdir" install
 
 	# remove the 2 lines below (and this) if there is no init.d script
-- 
GitLab