From 469786dd756f35e96bdbadadb38dd5bd10426e8c Mon Sep 17 00:00:00 2001
From: Natanael Copa <ncopa@alpinelinux.org>
Date: Sat, 17 Jan 2009 10:35:54 +0000
Subject: [PATCH] abuild: allow help (-h) even if there is no APKBUILD

---
 abuild | 11 +++++------
 1 file changed, 5 insertions(+), 6 deletions(-)

diff --git a/abuild b/abuild
index 6da844f1a854..23cc64ebb8a0 100755
--- a/abuild
+++ b/abuild
@@ -536,7 +536,7 @@ usage() {
 	echo " -u  Recursively build and upgrade dependencies (using sudo)"
 	echo ""
 	echo "Commands:"
-	echo "  checksum    Generate checksum to be included in $APKBUILD"
+	echo "  checksum    Generate checksum to be included in APKBUILD"
 	echo "  fetch       Fetch sources to \$SRCDEST and verify checksums"
 	echo "  sanitycheck Basic sanity check of APKBUILD"
 	echo "  md5check    Check md5sums"
@@ -555,12 +555,7 @@ usage() {
 	exit 0
 }
 
-
-# source the buildfile
 APKBUILD="${APKBUILD:-./APKBUILD}"
-[ -f "$APKBUILD" ] || die "Could not find $APKBUILD (PWD=$PWD)"
-. "$APKBUILD"
-
 unset force
 unset recursive
 while getopts "fhi:kip:qrs:u" opt; do
@@ -579,6 +574,10 @@ while getopts "fhi:kip:qrs:u" opt; do
 done
 shift $(( $OPTIND - 1 ))
 
+# source the buildfile
+[ -f "$APKBUILD" ] || die "Could not find $APKBUILD (PWD=$PWD)"
+. "$APKBUILD"
+
 # If we are handling a sub package then reset subpackages
 if [ -n "$subpkgname" ]; then
 	subpackages=
-- 
GitLab