diff --git a/abuild b/abuild
index 6da844f1a8544d5306efb857591738af8340ed9a..23cc64ebb8a0c764c261772ea8771356d60a4b78 100755
--- a/abuild
+++ b/abuild
@@ -536,7 +536,7 @@ usage() {
 	echo " -u  Recursively build and upgrade dependencies (using sudo)"
 	echo ""
 	echo "Commands:"
-	echo "  checksum    Generate checksum to be included in $APKBUILD"
+	echo "  checksum    Generate checksum to be included in APKBUILD"
 	echo "  fetch       Fetch sources to \$SRCDEST and verify checksums"
 	echo "  sanitycheck Basic sanity check of APKBUILD"
 	echo "  md5check    Check md5sums"
@@ -555,12 +555,7 @@ usage() {
 	exit 0
 }
 
-
-# source the buildfile
 APKBUILD="${APKBUILD:-./APKBUILD}"
-[ -f "$APKBUILD" ] || die "Could not find $APKBUILD (PWD=$PWD)"
-. "$APKBUILD"
-
 unset force
 unset recursive
 while getopts "fhi:kip:qrs:u" opt; do
@@ -579,6 +574,10 @@ while getopts "fhi:kip:qrs:u" opt; do
 done
 shift $(( $OPTIND - 1 ))
 
+# source the buildfile
+[ -f "$APKBUILD" ] || die "Could not find $APKBUILD (PWD=$PWD)"
+. "$APKBUILD"
+
 # If we are handling a sub package then reset subpackages
 if [ -n "$subpkgname" ]; then
 	subpackages=