diff --git a/main/crystalhd-git-grsec/0001-driver-remove-devinit-and-devexit-for-linux-3.8.patch b/main/crystalhd-git-grsec/0001-driver-remove-devinit-and-devexit-for-linux-3.8.patch
deleted file mode 100644
index a5b0eb2cdab383c7e05c48b3bdc643764af9010a..0000000000000000000000000000000000000000
--- a/main/crystalhd-git-grsec/0001-driver-remove-devinit-and-devexit-for-linux-3.8.patch
+++ /dev/null
@@ -1,106 +0,0 @@
-From 40aab27139c6e2291142fc8d93e4651effdeef90 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Tue, 12 Mar 2013 09:45:31 +0000
-Subject: [PATCH] driver: remove devinit and devexit for linux-3.8
-
-devinit and devexit were removed from kernel version 3.8 and using it
-causes compile problems.
-
-Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
----
- driver/linux/crystalhd_cmds.c |  4 ++--
- driver/linux/crystalhd_lnx.c  | 14 +++++++-------
- 2 files changed, 9 insertions(+), 9 deletions(-)
-
-diff --git a/driver/linux/crystalhd_cmds.c b/driver/linux/crystalhd_cmds.c
-index cecd710..f3d26e0 100644
---- a/driver/linux/crystalhd_cmds.c
-+++ b/driver/linux/crystalhd_cmds.c
-@@ -1093,7 +1093,7 @@ BC_STATUS crystalhd_user_open(struct crystalhd_cmd *ctx,
-  *
-  * Called at the time of driver load.
-  */
--BC_STATUS __devinit crystalhd_setup_cmd_context(struct crystalhd_cmd *ctx,
-+BC_STATUS crystalhd_setup_cmd_context(struct crystalhd_cmd *ctx,
- 				    struct crystalhd_adp *adp)
- {
- 	struct device *dev = &adp->pdev->dev;
-@@ -1136,7 +1136,7 @@ BC_STATUS __devinit crystalhd_setup_cmd_context(struct crystalhd_cmd *ctx,
-  *
-  * Called at the time of driver un-load.
-  */
--BC_STATUS __devexit crystalhd_delete_cmd_context(struct crystalhd_cmd *ctx)
-+BC_STATUS crystalhd_delete_cmd_context(struct crystalhd_cmd *ctx)
- {
- 	dev_dbg(chddev(), "Deleting Command context..\n");
- 
-diff --git a/driver/linux/crystalhd_lnx.c b/driver/linux/crystalhd_lnx.c
-index 64e66ad..8608aea 100644
---- a/driver/linux/crystalhd_lnx.c
-+++ b/driver/linux/crystalhd_lnx.c
-@@ -431,7 +431,7 @@ static const struct file_operations chd_dec_fops = {
- 	.llseek		= noop_llseek,
- };
- 
--static int __devinit chd_dec_init_chdev(struct crystalhd_adp *adp)
-+static int chd_dec_init_chdev(struct crystalhd_adp *adp)
- {
- 	struct device *xdev = &adp->pdev->dev;
- 	struct device *dev;
-@@ -498,7 +498,7 @@ fail:
- 	return rc;
- }
- 
--static void __devexit chd_dec_release_chdev(struct crystalhd_adp *adp)
-+static void chd_dec_release_chdev(struct crystalhd_adp *adp)
- {
- 	crystalhd_ioctl_data *temp = NULL;
- 	if (!adp)
-@@ -523,7 +523,7 @@ static void __devexit chd_dec_release_chdev(struct crystalhd_adp *adp)
- 	/*crystalhd_delete_elem_pool(adp); */
- }
- 
--static int __devinit chd_pci_reserve_mem(struct crystalhd_adp *pinfo)
-+static int chd_pci_reserve_mem(struct crystalhd_adp *pinfo)
- {
- 	struct device *dev = &pinfo->pdev->dev;
- 	int rc;
-@@ -582,7 +582,7 @@ static int __devinit chd_pci_reserve_mem(struct crystalhd_adp *pinfo)
- 	return 0;
- }
- 
--static void __devexit chd_pci_release_mem(struct crystalhd_adp *pinfo)
-+static void chd_pci_release_mem(struct crystalhd_adp *pinfo)
- {
- 	if (!pinfo)
- 		return;
-@@ -597,7 +597,7 @@ static void __devexit chd_pci_release_mem(struct crystalhd_adp *pinfo)
- }
- 
- 
--static void __devexit chd_dec_pci_remove(struct pci_dev *pdev)
-+static void chd_dec_pci_remove(struct pci_dev *pdev)
- {
- 	struct crystalhd_adp *pinfo;
- 	BC_STATUS sts = BC_STS_SUCCESS;
-@@ -625,7 +625,7 @@ static void __devexit chd_dec_pci_remove(struct pci_dev *pdev)
- 	g_adp_info = NULL;
- }
- 
--static int __devinit chd_dec_pci_probe(struct pci_dev *pdev,
-+static int chd_dec_pci_probe(struct pci_dev *pdev,
- 			     const struct pci_device_id *entry)
- {
- 	struct device *dev = &pdev->dev;
-@@ -815,7 +815,7 @@ MODULE_DEVICE_TABLE(pci, chd_dec_pci_id_table);
- static struct pci_driver bc_chd_driver = {
- 	.name     = "crystalhd",
- 	.probe    = chd_dec_pci_probe,
--	.remove   = __devexit_p(chd_dec_pci_remove),
-+	.remove   = chd_dec_pci_remove,
- 	.id_table = chd_dec_pci_id_table,
- 	.suspend  = chd_dec_pci_suspend,
- 	.resume   = chd_dec_pci_resume
--- 
-1.8.1.5
-
diff --git a/main/crystalhd-git-grsec/APKBUILD b/main/crystalhd-git-grsec/APKBUILD
deleted file mode 100644
index 89ebf33e22649b3af96800cb003691c09cf1e876..0000000000000000000000000000000000000000
--- a/main/crystalhd-git-grsec/APKBUILD
+++ /dev/null
@@ -1,118 +0,0 @@
-# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer:
-
-_flavor=${FLAVOR:-grsec}
-_realname=crystalhd-git
-_name=$_realname-$_flavor
-
-_kpkg=linux-$_flavor
-_kver=3.9.5
-_kpkgrel=0
-
-_mypkgrel=0
-_date=20121126
-
-# source the kernel version
-if [ -f ../../main/linux-$_flavor/APKBUILD ]; then
-        . ../../main/linux-$_flavor/APKBUILD
-        [ "$_kver" != "$pkgver" ] && die "$_name: Please update _kver to $pkgver"
-        [ "$_kpkgrel" != "$pkgrel" ] && die "$_name: Please update _kpkgrel to $pkgrel"
-fi
-
-_kernelver=$_kver-r$_kpkgrel
-_abi_release=${_kver}-${_kpkgrel}-${_flavor}
-
-pkgname=$_name
-pkgver=20121205
-pkgrel=$(($_kpkgrel + $_mypkgrel))
-pkgdesc="Broadcom CrystalHD kernel driver"
-url="http://git.linuxtv.org/jarod/crystalhd.git"
-arch="all"
-license="GPL2"
-depends=""
-depends_dev=""
-makedepends="$depends_dev automake autoconf linux-$_flavor-dev=$_kernelver"
-install=""
-subpackages="$pkgname-dev libcrystalhd"
-source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-${_date}.tar.gz
-	crystalhd-use_8_DMA_buffers-0.1.patch
-	0001-driver-remove-devinit-and-devexit-for-linux-3.8.patch
-	"
-
-_giturl="git://linuxtv.org/jarod/crystalhd.git"
-_upload="dev.alpinelinux.org:/archive/$pkgname/"
-_libdir="$srcdir/$pkgname-$_date/linux_lib/libcrystalhd"
-_kerdir="$srcdir/$pkgname-$_date/driver/linux"
-_builddir="$srcdir/$pkgname-$_date"
-
-snapshot() {
-        local _date=$(date +%Y%m%d)
-        local _pkg=$pkgname-$_date.tar.gz
-        mkdir -p "$srcdir"
-        cd "$srcdir"
-        msg "Creating snapshot: $_pkg"
-        rm -rf ${_giturl##*/}
-        git clone --depth=1 --bare $_giturl || return 1
-        git --git-dir ${_giturl##*/} archive -o $_pkg \
-                --prefix=$pkgname-$_date/ HEAD \
-                || return 1
-        msg "Uploading to $_upload"
-        rsync -Lave ssh $_pkg $_upload || return 1
-        cd "$startdir"
-        sed -i -e "s/^pkgver=.*/pkgver=$_date/" \
-                APKBUILD || return 1
-        abuild checksum
-}
-
-prepare() {
-	local i
-	cd "$_builddir"
-	for i in $source; do
-		case $i in
-		*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
-		esac
-	done
-}
-
-build() {
-	cd "$_libdir"
-	msg "building library"
-	make || return 1
-	cd "$_kerdir"
-	msg "building module"
-	export GCC_SPECS=/usr/share/gcc/hardenednopie.specs
-	autoconf
-	./configure --prefix=/usr \
-		--with-kernel-path=/usr/src/linux-headers-${_abi_release}
-	make || return 1
-}
-
-package() {
-	cd "$_kerdir"
-	mkdir -p "$pkgdir"/lib/modules/"$_abi_release"/kernel/drivers/video/broadcom
-	install -m 0644 crystalhd.ko \
-		"$pkgdir"/lib/modules/"$_abi_release"/kernel/drivers/video/broadcom
-	cd "$_libdir"
-	make DESTDIR="$pkgdir" install || return 1
-}
-
-dev() {
-	default_dev
-}
-
-libcrystalhd() {
-	pkgdesc="Broadcom CrystalHD kernel library"
-	mkdir -p "$subpkgdir"/usr
-	mv "$pkgdir"/usr/lib \
-		"$subpkgdir"/usr/
-}
-
-md5sums="3459e3b206702cea539f09fb9abbb4f8  crystalhd-git-grsec-20121126.tar.gz
-e617ef3212dd46749d61247b5cbb51bd  crystalhd-use_8_DMA_buffers-0.1.patch
-2306287aa1ca2c1bff6a7fb9bf547467  0001-driver-remove-devinit-and-devexit-for-linux-3.8.patch"
-sha256sums="46c432fd7b53f6a5e54f53180e5959ef6afeeeffc4e2b4eb0ed294f84634b8f7  crystalhd-git-grsec-20121126.tar.gz
-117e6f4bf1fbcda644e6a823f6d77692df347e34af26773602adcbb70414adba  crystalhd-use_8_DMA_buffers-0.1.patch
-0afb00f7555ec3645bdb10b2e7da016838663bb8e2a66341b4a7a0b03fc86f7b  0001-driver-remove-devinit-and-devexit-for-linux-3.8.patch"
-sha512sums="22fd749c7141e3f21810bfa9811e2554051021d8e0a088de4e3af9a97c34535e7b2a1f7b7b2e28f27ebc80362afd737e9a420db008aadfafd140cbe87b2cc289  crystalhd-git-grsec-20121126.tar.gz
-4a5738d5c9acc90e54c368dee4aabc573778854a4f45db9851d9b97c41313a38060d6cb38ac8b4e839076e4f1c6c702a254491cff6e42c8f98c7042d000a2ebb  crystalhd-use_8_DMA_buffers-0.1.patch
-2baa034141a7a45e2274a7a1a820213c2c802531cbeb8a645bb2fc6486364be0a9aba38fd54e6d0232aeb63a963851e4eddaef03e6fda9d7b77c964c14c1d2b6  0001-driver-remove-devinit-and-devexit-for-linux-3.8.patch"
diff --git a/main/crystalhd-git-grsec/crystalhd-use_8_DMA_buffers-0.1.patch b/main/crystalhd-git-grsec/crystalhd-use_8_DMA_buffers-0.1.patch
deleted file mode 100644
index 1b9150ea7b620b1095632051301fab15a91b0b0e..0000000000000000000000000000000000000000
--- a/main/crystalhd-git-grsec/crystalhd-use_8_DMA_buffers-0.1.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/include/bc_dts_glob_lnx.h
-+++ b/include/bc_dts_glob_lnx.h
-@@ -76,7 +76,7 @@
- 	BC_LINK_MAX_OPENS	= 3,		/* Maximum simultaneous opens*/
- 	BC_LINK_MAX_SGLS	= 1024,		/* Maximum SG elements 4M/4K */
- 	BC_TX_LIST_CNT		= 2,		/* Max Tx DMA Rings */
--	BC_RX_LIST_CNT		= 16,		/* Max Rx DMA Rings*/
-+	BC_RX_LIST_CNT		= 8,		/* Max Rx DMA Rings*/
- 	BC_PROC_OUTPUT_TIMEOUT	= 2000,		/* Milliseconds */
- 	BC_INFIFO_THRESHOLD	= 0x10000,
- };