diff --git a/testing/py3-sortedcollections/APKBUILD b/testing/py3-sortedcollections/APKBUILD
new file mode 100644
index 0000000000000000000000000000000000000000..78baa7e014b2a0c492a63def65e6aae72ce8ee83
--- /dev/null
+++ b/testing/py3-sortedcollections/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Sam Whited <sam@samwhited.com>
+# Maintainer: Sam Whited <sam@samwhited.com>
+pkgname=py3-sortedcollections
+_pkgname=sortedcollections
+pkgver=2.1.0
+pkgrel=0
+pkgdesc="A Python library containing various sorted collections."
+url="https://pypi.org/project/sortedcollections/"
+arch="all"
+license="Apache-2.0"
+depends="python3"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+options="!check" # tests not included in source package.
+
+build() {
+	python3 setup.py build
+}
+
+package() {
+	python3 setup.py install --prefix=/usr --root="$pkgdir"
+	install -Dm644 LICENSE README.rst -t "$pkgdir"/usr/share/licenses/$pkgname
+}
+
+sha512sums="
+e0ea72c24300c156bd9f9d40c42c92ad4a6391f7fa17675cf956a02617b9614aa329c24e3c7a9abd6662d45cf4f12f6d04296d69b287bae11b5f320481fd5748  sortedcollections-2.1.0.tar.gz
+"