community/calls: upgrade to 0.2.0

Calls is broken since its dependency libcallaudio-0 has been upgraded to
libcallaudio-0.1. Upgrade to latest version and add patches from
upstream MR on top to build against libcallaudio-0.1.

Fixes:
  / # apk add calls
  ERROR: unable to select packages:
    so:libcallaudio-0.so.0 (no such package):
      required by: calls-0.1.9-r0[so:libcallaudio-0.so.0]

Related: https://source.puri.sm/Librem5/calls/-/merge_requests/230
7 jobs for !17034 with fix-calls in 48 seconds (queued for 1 second)
detached
Status Job ID Name Coverage
  Lint
failed #297539
docker-alpine x86_64 allowed to fail
lint

00:00:10

 
  Build
failed #297544
docker-alpine ci-build aarch64
build-aarch64

00:00:06

failed #297545
docker-alpine ci-build armv7
build-armv7

00:00:10

failed #297543
docker-alpine ci-build ppc64le
build-ppc64le

00:00:08

failed #297542
docker-alpine ci-build s390x
build-s390x

00:00:08

failed #297541
docker-alpine ci-build x86
build-x86

00:00:02

failed #297540
docker-alpine ci-build x86_64
build-x86_64

00:00:03

 
Name Stage Failure
failed
build-armv7 Build
No job log
failed
build-s390x Build
No job log
failed
build-x86_64 Build
No job log
failed
build-x86 Build
No job log
failed
build-ppc64le Build
No job log
failed
lint Lint
No job log
failed
build-aarch64 Build
No job log