Commit d8a1ac99 authored by Rasmus Thomsen's avatar Rasmus Thomsen
Browse files

community/gnome-software: depend on gnome-software-plugin-apk on supported arches

That package enables APK integration for GNOME Software
parent fc43d775
......@@ -2,7 +2,7 @@
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=gnome-software
pkgver=3.36.0
pkgrel=4
pkgrel=5
pkgdesc="Software lets you install and update applications and system extensions"
url="https://wiki.gnome.org/Apps/Software"
arch="all !s390x !mips !mips64"
......@@ -22,6 +22,12 @@ case "$CARCH" in
x86*) makedepends="$makedepends fwupd-dev" ;;
esac
# gnome-software-plugin-apk is only a runtime dependency and unfortunately
# not available on other arches yet due to LDC.
case "$CARCH" in
x86_64|aarch64) depends="$depends gnome-software-plugin-apk" ;;
esac
build() {
case "$CARCH" in
x86*) conf="-Dfwupd=true" ;;
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment