Commit c8929f36 authored by Justin Berthault's avatar Justin Berthault Committed by Leo

community/py3-libvirt: upgrade to 6.7.0

parent 6969d50d
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=py3-libvirt
_pkgname=libvirt-python
pkgver=6.6.0
pkgver=6.7.0
pkgrel=0
pkgdesc="The libvirt virtualization API python binding"
url="http://libvirt.org"
arch="all"
license="LGPL-2.0-or-later"
makedepends="py3-setuptools python3-dev libvirt-dev"
source="https://libvirt.org/sources/python/$_pkgname-$pkgver.tar.gz
musl-gnuc-prereq.patch
"
source="https://libvirt.org/sources/python/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
replaces="py-libvirt" # Backwards compatibility
......@@ -28,5 +26,4 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="3524cd490cb43b19e0376f7e167c02f26b5eb96942df241cbe627d6437d9dacc0aa0225aae269cbab7d446294795881cbb207f5c26be02cd5b5d42911eda5819 libvirt-python-6.6.0.tar.gz
8aa1d814f8388ebff0736ee138c780323381cd4cf39b4a4faed2e2a1fe5911facc34505a85b0977d8b4240b8ce2f4a6d0414790693c4f45ff7d9592e9d6a3ff8 musl-gnuc-prereq.patch"
sha512sums="7d5a7f87abc01285c2030c9408838d4e1496d0d0316b9ab775749e49719fa66c20114aad2bd281d6783e2cb4d47ceac5ac60ac584e881288d0b0d9cc76d5b2cb libvirt-python-6.7.0.tar.gz"
--- libvirt-python-1.2.0.orig/libvirt-utils.h
+++ libvirt-python-1.2.0/libvirt-utils.h
@@ -28,6 +28,15 @@
# define MIN(a,b) (((a) < (b)) ? (a) : (b))
# endif
+# ifndef __GNUC_PREREQ
+# if defined __GNUC__ && defined __GNUC_MINOR__
+# define __GNUC_PREREQ(maj, min) \
+ ((__GNUC__ << 16) + __GNUC_MINOR__ >= ((maj) << 16) + (min))
+# else
+# define __GNUC_PREREQ(maj, min) 0
+# endif
+#endif
+
/**
* libvirt.h provides this as of version 1.2.0, but we want to be able
* to support older versions of libvirt so copy and paste the macro from
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment