Commit 1962476f authored by Bart Ribbers's avatar Bart Ribbers
Browse files

community/py3-lmdb: upgrade to 1.2.1

parent 034cd38c
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-lmdb
pkgver=1.1.1
pkgrel=1
pkgver=1.2.1
pkgrel=0
pkgdesc="Universal Python binding for the LMDB 'Lightning' Database"
url="https://github.com/jnwatson/py-lmdb/"
arch="all"
......@@ -17,12 +17,6 @@ checkdepends="py3-pytest"
source="https://github.com/jnwatson/py-lmdb/archive/py-lmdb_$pkgver.tar.gz"
builddir="$srcdir/py-lmdb-py-lmdb_$pkgver"
case "$CARCH" in
x86) _arch="i686" ;;
arm*) _arch="armv8l" ;;
*) _arch="$CARCH" ;;
esac
build() {
LMDB_FORCE_SYSTEM=1 python3 setup.py build
}
......@@ -36,4 +30,6 @@ package() {
LMDB_FORCE_SYSTEM=1 python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="36632934174bfb89dc239a9a1ba541ec2e9127dc7947e311188363e80eeb34a5ed35f8c9f3aff76228ef795b60acd6bc5660e1d441508a7a52b9a08eb97bb6f7 py-lmdb_1.1.1.tar.gz"
sha512sums="
78f27c618ec38077cad35a5ef7ee014561d32c0e3d8d9d7bc6f0341982622c855079fa1ac7072e326f92c1a0dc4a7c84b457c7f6c7277ed9b3db0dd0ad7c5c4b py-lmdb_1.2.1.tar.gz
"
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment