diff --git a/main/gtk+3.0/APKBUILD b/main/gtk+3.0/APKBUILD
index 43013e2174094137fe18a70819682ecb7dbee393..765595553eb8e15288cd25db9b94e0c6d140a39f 100644
--- a/main/gtk+3.0/APKBUILD
+++ b/main/gtk+3.0/APKBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=gtk+3.0
 pkgver=3.8.2
-pkgrel=0
+pkgrel=1
 pkgdesc="The GTK+ Toolkit (v3)"
 url="http://www.gtk.org/"
 install="$pkgname.post-install $pkgname.post-upgrade $pkgname.post-deinstall"
@@ -52,6 +52,7 @@ source="http://ftp.gnome.org/pub/gnome/sources/gtk+/${pkgver%.*}/gtk+-$pkgver.ta
 
 
 _builddir="$srcdir"/gtk+-$pkgver
+
 build() {
 	cd "$_builddir"
 	./configure \
@@ -66,6 +67,10 @@ build() {
 	# https://bugzilla.gnome.org/show_bug.cgi?id=676087
 	echo "#define HAVE_ISNAN 1" >> config.h
 	echo "#define HAVE_ISINF 1" >> config.h
+
+	# https://bugzilla.gnome.org/show_bug.cgi?id=655517
+	sed -i 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool || return 1
+
 	make || return 1
 }