diff --git a/main/udisks2/APKBUILD b/main/udisks2/APKBUILD
index b752d1e480efc2e9a86bffa92b6a68945f939f12..3d931cebf0396b4d3e3f02fdc78f9c914aca8c57 100644
--- a/main/udisks2/APKBUILD
+++ b/main/udisks2/APKBUILD
@@ -1,8 +1,8 @@
 # Contributor: Natanael Copa <ncopa@alpinelinux.org>
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=udisks2
-pkgver=1.97.0
-pkgrel=1
+pkgver=1.99.0
+pkgrel=0
 pkgdesc="Disk Manager"
 url="http://www.freedesktop.org/wiki/Software/udisks"
 arch="all"
@@ -16,7 +16,7 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-libs"
 source="http://udisks.freedesktop.org/releases/udisks-$pkgver.tar.bz2
 	O_CLOEXEC.patch
 	sys-wait.patch
-	udisks2-root-bound-mount-fix.patch"
+	"
 
 _builddir="$srcdir"/udisks-$pkgver
 prepare() {
@@ -54,7 +54,6 @@ libs() {
 		"$subpkgdir"/usr/lib/
 }
 
-md5sums="8ae4ef908ab706789e0e2b33d8810877  udisks-1.97.0.tar.bz2
+md5sums="b42f1d36ad4606622a9989e166fbae20  udisks-1.99.0.tar.bz2
 fd70ee4163c5bfd9bd474c28a2548c46  O_CLOEXEC.patch
-4c7aa82c180c809f565c55325ce9eb20  sys-wait.patch
-11d6256cd2c2aab25e824bf613061925  udisks2-root-bound-mount-fix.patch"
+4c7aa82c180c809f565c55325ce9eb20  sys-wait.patch"
diff --git a/main/udisks2/udisks2-root-bound-mount-fix.patch b/main/udisks2/udisks2-root-bound-mount-fix.patch
deleted file mode 100644
index 53d711baa650b560143cc49f25f43d39df6accba..0000000000000000000000000000000000000000
--- a/main/udisks2/udisks2-root-bound-mount-fix.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From e0b8ffe3099735fefd64973e6575c67ac0759be2 Mon Sep 17 00:00:00 2001
-From: David Zeuthen <davidz@redhat.com>
-Date: Tue, 15 May 2012 14:17:22 +0000
-Subject: Bug 49842 – Unhandled rootfs on bind mount
-
-Don't ignore a mount just because if a subtree of the filesystem is
-mounted. Because if we do this, we may wrongly conclude the device is
-not mounted at all, which then means that it's visible in the desktop
-UI and subject to automounting.
-
-In the future, we may want a "a(ss) MountPointsFull" property that in
-addition to the mount point also contains the subtree that is mounted
-at said mountpoint.
-
-https://bugs.freedesktop.org/show_bug.cgi?id=49842
-
-Signed-off-by: David Zeuthen <davidz@redhat.com>
----
-diff --git a/src/udisksmountmonitor.c b/src/udisksmountmonitor.c
-index 43adaa5..36e1476 100644
---- a/src/udisksmountmonitor.c
-+++ b/src/udisksmountmonitor.c
-@@ -433,10 +433,6 @@ udisks_mount_monitor_get_mountinfo (UDisksMountMonitor  *monitor,
-           continue;
-         }
- 
--      /* ignore mounts where only a subtree of a filesystem is mounted */
--      if (g_strcmp0 (encoded_root, "/") != 0)
--        continue;
--
-       /* Temporary work-around for btrfs, see
-        *
-        *  https://bugzilla.redhat.com/show_bug.cgi?id=495152#c31
---
-cgit v0.9.0.2-2-gbebe