diff --git a/community/bam/APKBUILD b/community/bam/APKBUILD
new file mode 100644
index 0000000000000000000000000000000000000000..e48d74f2c0026b3dc21a341619624154395326c4
--- /dev/null
+++ b/community/bam/APKBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
+
+pkgname=bam
+#teeworlds is sole user of bam, and requires 0.4.x currently
+pkgver=0.4.0
+pkgrel=0
+pkgdesc='Fast and flexible build system using Lua'
+arch=all
+url=http://github.com/matricks/bam
+license='ZLIB'
+
+#source="$pkgname-$pkgver.tar.gz::https://github.com/matricks/bam/archive/v$pkgver.tar.gz"
+source="https://downloads.teeworlds.com/bam-$pkgver.tar.gz"
+
+build() {
+	cd "$srcdir"/$pkgname-$pkgver
+	sh make_unix.sh || return 1
+}
+
+package() {
+	cd "$srcdir"/$pkgname-$pkgver
+	install -Dm755 bam "$pkgdir"/usr/bin/bam || return 1
+	install -Dm755 license.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE \
+		|| return 1
+}
+
+md5sums="2f8e8336b8884110e8a355b12c9fa58a  bam-0.4.0.tar.gz"
+sha256sums="5e4e4920b4d265da582f66774e9b1ec8ddfbe75ddc028fba86c12f686ea18db3  bam-0.4.0.tar.gz"
+sha512sums="c599cdf3618d317a5d304febd2e59d1116fc5819cdaf49969fdc25f88ed8f3e25831861c0c7fea05059d8af7085b654a7732bd89086bc166661b932d168ee2ca  bam-0.4.0.tar.gz"
diff --git a/main/teeworlds/APKBUILD b/community/teeworlds/APKBUILD
similarity index 100%
rename from main/teeworlds/APKBUILD
rename to community/teeworlds/APKBUILD
diff --git a/main/bam/APKBUILD b/main/bam/APKBUILD
deleted file mode 100644
index 5e2e6938e4f37cd055a3c5209ecbe10e19233686..0000000000000000000000000000000000000000
--- a/main/bam/APKBUILD
+++ /dev/null
@@ -1,27 +0,0 @@
-# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
-
-pkgname=bam
-pkgver=0.5.0
-pkgrel=0
-pkgdesc='Fast and flexible build system using Lua'
-arch=all
-url=http://github.com/matricks/bam
-license='ZLIB'
-source="$pkgname-$pkgver.tar.gz::https://github.com/matricks/bam/archive/v$pkgver.tar.gz"
-
-build() {
-  cd "$srcdir"/$pkgname-$pkgver
-  sh make_unix.sh || return 1
-}
-
-package() {
-  cd "$srcdir"/$pkgname-$pkgver
-  install -Dm755 bam "$pkgdir"/usr/bin/bam || return 1
-  install -Dm755 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING \
-    || return 1
-}
-
-md5sums="08db8dfc32fb817947c39000092a55d4  bam-0.5.0.tar.gz"
-sha256sums="16c0bccb6c5dee62f4381acaa004dd4f7bc9a32c10d0f2a40d83ea7e2ae25998  bam-0.5.0.tar.gz"
-sha512sums="e5af8789b6d6617be424481111ed9838c6dbe35bc41010608ef654810c9ff4d6ab15aafb904a808ddb4f1009b5d11232dd67160abda51cf3dd970a9557af96f1  bam-0.5.0.tar.gz"