main/haproxy: backport LTS version from edge and upgrade to 2.2.2

add note to use only LTS versions

take maintainership according to Natanael Copa ask on #alpine-devel IRC
channel
7 jobs for !10935 with 3.12-stable-haproxy-2.2.2 in 11 minutes and 38 seconds (queued for 4 seconds)
latest detached
Status Job ID Name Coverage
  Lint
failed #177116
x86_64 docker-alpine allowed to fail
lint

00:05:16

 
  Build
passed #177121
aarch64 ci-build docker-alpine
build-aarch64

00:02:22

passed #177122
armv7 ci-build docker-alpine
build-armv7

00:02:40

passed #177120
ppc64le ci-build docker-alpine
build-ppc64le

00:04:40

passed #177119
s390x ci-build docker-alpine
build-s390x

00:01:41

passed #177118
x86 ci-build docker-alpine
build-x86

00:02:01

passed #177117
x86_64 ci-build docker-alpine
build-x86_64

00:01:45

 
Name Stage Failure
failed
lint Lint
No job log