Commit 8f02a079 authored by A. Klitzing's avatar A. Klitzing Committed by A. Klitzing
Browse files

community/clazy: upgrade to 1.8

parent d9195600
Pipeline #59908 failed with stages
in 1 minute and 3 seconds
# Maintainer: André Klitzing <aklitzing@gmail.com>
# Contributor: André Klitzing <aklitzing@gmail.com>
pkgname=clazy
pkgver=1.7
pkgver=1.8
pkgrel=0
pkgdesc="Qt oriented code checker based on clang framework"
url="https://github.com/KDE/clazy"
......@@ -15,12 +15,13 @@ source="https://download.kde.org/stable/clazy/$pkgver/src/clazy-$pkgver.tar.xz"
build() {
cmake -B build .\
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_LIBDIR=/usr/lib \
-DCMAKE_INSTALL_PREFIX=/usr
make -C build
cmake --build build
}
package() {
make -C build DESTDIR="$pkgdir" install
DESTDIR="$pkgdir" cmake --install "$srcdir/build"
}
sha512sums="3dba993140f3d69aac8d9cf3fa49db990185928647193220b689773bbca70f9fd9ee7fc52022e6029b3c0c81800301a593bd79edee7e1fa6c5884782d390ced6 clazy-1.7.tar.xz"
sha512sums="c43a393721a5235ddcd653f9c322e0a215f86add3b1ce42f849677c108cd21209693c6e8f225171db88032c75596722109ee01bc53db4af90fe7652f27c1eba5 clazy-1.8.tar.xz"
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment