testing/py3-grpcio: upgrade to 1.28.1

Disable on ppc64le to avoid an error:

    third_party/abseil-cpp/absl/base/internal/unscaledcycleclock.cc:100:2: error: #error Must implement UnscaledCycleClock::Frequency()

linux-headers is now a dependency:
https://github.com/grpc/grpc/issues/21918#issuecomment-582589140

abseil is a git submodule and therefore must be downloaded separately:
https://github.com/grpc/grpc/issues/21956#issuecomment-584776736

See also community/grpc
7 jobs for !6454 with py3-grpcio in 31 seconds
detached
Status Job ID Name Coverage
  Lint
failed #86847
docker-alpine x86_64 allowed to fail
lint

00:00:15

 
  Build
failed #86852
docker-alpine ci-build aarch64
build-aarch64

00:00:07

failed #86853
docker-alpine ci-build armv7
build-armv7

00:00:09

failed #86851
docker-alpine ci-build ppc64le
build-ppc64le

00:00:10

failed #86850
docker-alpine ci-build s390x
build-s390x

00:00:07

failed #86849
docker-alpine ci-build x86
build-x86

00:00:14

failed #86848
docker-alpine ci-build x86_64
build-x86_64

00:00:14

 
Name Stage Failure
failed
lint Lint
No job log
failed
build-aarch64 Build
No job log
failed
build-s390x Build
No job log
failed
build-armv7 Build
No job log
failed
build-ppc64le Build
No job log
failed
build-x86 Build
No job log
failed
build-x86_64 Build
No job log