Unverified Commit 3da9036a authored by Marian Buschsieweke's avatar Marian Buschsieweke
Browse files

testing/micropython: drop patch not needed

the fix for clobbered variable on longjmp was intended to get this
compiling on ppc64le. But since this still fails, we do not really
need the patch.
parent 4330dc61
Pipeline #77148 failed with stages
in 1 minute and 33 seconds
......@@ -2,7 +2,7 @@
# Maintainer: Marian <marian.buschsieweke@ovgu.de>
pkgname=micropython
pkgver=1.14
pkgrel=0
pkgrel=1
pkgdesc="lean and efficient Python implementation for MCUs and constrained systems"
url="https://www.micropython.org/"
......@@ -19,7 +19,6 @@ source="micropython-$pkgver.tar.gz::https://github.com/micropython/micropython/a
micropython-1.9.4-prevent-stripping.patch
no_ussl.patch
no_legacy_berkeley_db.patch
fix_clobbered_longjmp.patch
"
build() {
......@@ -59,5 +58,4 @@ cross() {
sha512sums="6a6a8fc0306e651aca81a67d09ca7bc4d94f655056ff76b09f8913e88daac30e5f74d486dd5ad8bd5ebdf81115cf1d88a9b21f118516352a5c8023fb44370792 micropython-1.14.tar.gz
8f994394f42d7fed5fa35b62c01c37ebea3b487c029d659134a263ef8d65e1ec17bec755fdf57cde2f234969bc4f7f4ab30858562d7f8cdb2bc6cb819ba2ae0d micropython-1.9.4-prevent-stripping.patch
9a6cd131c8875a9d320653b7b93d46a759eee3255e25763eb8de6934b3035f691e497eafc9412320f13c5921a384d42d6e60ea3eb3d65f3a6101dae9be514f3c no_ussl.patch
e86ad02ef746605f2f685ae776a6ad6ea39ae6e57fa0869a0c03895fd581647de20fa7e6aaeebac45e7302a63451d625208b1356ee2f35a66df70ac2755a25ff no_legacy_berkeley_db.patch
a326877348391e1d87ec6209274dd68de3775fd64d209a2ac7f13ce860e74255107a0fbe5fa555eda5a28885d9b8ce7886d9f2012242ec6da83fac464bbc6706 fix_clobbered_longjmp.patch"
e86ad02ef746605f2f685ae776a6ad6ea39ae6e57fa0869a0c03895fd581647de20fa7e6aaeebac45e7302a63451d625208b1356ee2f35a66df70ac2755a25ff no_legacy_berkeley_db.patch"
Fix the following error:
main.c: In function 'main_':
main.c:595:22: error: variable 'subpkg_tried' might be clobbered by 'longjmp' or 'vfork' [-Werror=clobbered]
595 | bool subpkg_tried = false;
| ^~~~~~~~~~~~
--- micropython-1.14.orig/ports/unix/main.c
+++ micropython-1.14/ports/unix/main.c
@@ -592,7 +592,7 @@
mp_obj_t mod;
nlr_buf_t nlr;
- bool subpkg_tried = false;
+ static bool subpkg_tried = false;
reimport:
if (nlr_push(&nlr) == 0) {
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment