From ef75f8fad9e542aaa30a85cb2c3367cd61221f10 Mon Sep 17 00:00:00 2001
From: Keith Maxwell <keith.maxwell@gmail.com>
Date: Thu, 9 May 2019 14:24:20 +0100
Subject: [PATCH] testing/beancount: new aport

Closes GH-7749
---
 testing/beancount/APKBUILD | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)
 create mode 100644 testing/beancount/APKBUILD

diff --git a/testing/beancount/APKBUILD b/testing/beancount/APKBUILD
new file mode 100644
index 000000000000..02c5bd2658fa
--- /dev/null
+++ b/testing/beancount/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Keith Maxwell <keith.maxwell@gmail.com>
+# Maintainer: Keith Maxwell <keith.maxwell@gmail.com>
+pkgname=beancount
+_pyname=beancount
+pkgver=2.2.1
+pkgrel=0
+pkgdesc="Double-Entry Accounting from Text Files"
+url="http://furius.ca/beancount/"
+arch="all"
+license="GPL-2.0-only"
+depends="python3 py3-dateutil py3-ply py3-bottle py3-lxml py3-magic
+	py3-beautifulsoup4 py3-requests py3-chardet
+	py3-google-api-python-client"
+makedepends="python3-dev py3-setuptools"
+checkdepends="py3-pytest"
+source="$pkgname-$pkgver.tar.gz::https://bitbucket.org/blais/beancount/get/$pkgver.tar.gz"
+# 0cd71fede0f3347a14ac2b7ed240b74d56a38887 2.2.1
+builddir="$srcdir"/blais-$pkgname-0cd71fede0f3
+
+build() {
+	python3 setup.py build
+	python3 setup.py build_ext -i
+}
+
+package() {
+	python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+check() {
+	python3 -m pytest beancount \
+		--deselect=beancount/utils/file_type_test.py::TestFileType::test_xhtml \
+		--deselect=beancount/loader_test.py::TestLoadIncludesEncrypted::test_include_encrypted
+}
+
+sha512sums="0be8614631aacdcd28537ca11cf2d8e4a9ca8a45ce272bbf986417b24b2d18366d43e48d6ee1706a617382a546dc2fad91244bafbc442f55a19f172a7d5a3709  beancount-2.2.1.tar.gz"
-- 
GitLab