From dc83ffa9928169e1354b43bf79eddf57c394a440 Mon Sep 17 00:00:00 2001
From: Drew DeVault <sir@cmpwn.com>
Date: Thu, 9 Jan 2020 14:53:48 -0500
Subject: [PATCH] community/alertmanager: fix LDFLAGS issues

This should(?) fix the build on aarch64.
---
 community/alertmanager/APKBUILD | 31 ++++++++++++++-----------------
 1 file changed, 14 insertions(+), 17 deletions(-)

diff --git a/community/alertmanager/APKBUILD b/community/alertmanager/APKBUILD
index e61bbb252689..56a02011c618 100644
--- a/community/alertmanager/APKBUILD
+++ b/community/alertmanager/APKBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Drew DeVault <sir@cmpwn.com>
 pkgname=alertmanager
 pkgver=0.20.0
-pkgrel=0
+pkgrel=1
 pkgdesc="Prometheus Alertmanager"
 url="https://github.com/prometheus/alertmanager"
 arch="all"
@@ -18,22 +18,19 @@ builddir="$srcdir/$pkgname-$pkgver"
 options="!check" # timing-sensitive upstream tests
 
 build() {
-	ldflags="-extldflags $LDFLAGS \
-			-X github.com/prometheus/common/version.Version=$pkgver \
-			-X github.com/prometheus/common/version.Revision=$pkgrel \
-			-X github.com/prometheus/common/version.Branch=Alpine \
-			-X github.com/prometheus/common/version.BuildUser=Alpine \
-			-X github.com/prometheus/common/version.BuildDate=2020-01-08"
-	go build \
-		-trimpath \
-		-mod=vendor \
-		-ldflags "$ldflags" \
-		./cmd/alertmanager
-	go build \
-		-trimpath \
-		-mod=vendor \
-		-ldflags "$ldflags" \
-		./cmd/amtool
+	for cmd in amtool alertmanager
+	do
+		go build \
+			-trimpath \
+			-mod=vendor \
+			-ldflags "-extldflags \"$LDFLAGS\" \
+				-X github.com/prometheus/common/version.Version=$pkgver \
+				-X github.com/prometheus/common/version.Revision=$pkgrel \
+				-X github.com/prometheus/common/version.Branch=Alpine \
+				-X github.com/prometheus/common/version.BuildUser=Alpine \
+				-X github.com/prometheus/common/version.BuildDate=2020-01-08" \
+			./cmd/$cmd
+	done
 }
 
 check() {
-- 
GitLab