From ad309933eaa83e774c3d810fc6edefc2d3201484 Mon Sep 17 00:00:00 2001
From: Natanael Copa <ncopa@alpinelinux.org>
Date: Wed, 8 May 2019 14:10:06 +0000
Subject: [PATCH] community/go: don't die in global scope

we have tools that parse APKBUILDs in aports so we should never die from
global scope.
---
 community/go/APKBUILD | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/community/go/APKBUILD b/community/go/APKBUILD
index 34b70f40a9ba..200489794a16 100644
--- a/community/go/APKBUILD
+++ b/community/go/APKBUILD
@@ -62,7 +62,7 @@ mips)   export GOARCH="mips" GOMIPS=softfloat ;;
 mips64) export GOARCH="mips64" GOMIPS64=softfloat ;;
 mips64el) export GOARCH="mips64le" GOMIPS64=softfloat ;;
 mipsel) export GOARCH="mipsle" GOMIPS=softfloat ;;
-*)      die "Unsupported arch" ;;
+*)      export GOARCH="unsupported";;
 esac
 
 builddir="$srcdir"/go
-- 
GitLab