diff --git a/community/e2tools/APKBUILD b/community/e2tools/APKBUILD
index 673251551017bc0dcf5fbad08e270f21e79dab5e..fc34fe4253ede37c4da24acd8ccaf2045d30ab93 100644
--- a/community/e2tools/APKBUILD
+++ b/community/e2tools/APKBUILD
@@ -1,24 +1,16 @@
 # Contributor: Daniel Santana <daniel@santana.tech>
 # Maintainer: Daniel Santana <daniel@santana.tech>
 pkgname=e2tools
-pkgver=0.0.16
-pkgrel=1
+pkgver=0.1.0
+pkgrel=0
 pkgdesc="Utilities for manipulating files in an ext2/ext3 filesystem"
 url="https://e2tools.github.io/"
 arch="all"
 license="GPL-2.0-only"
 makedepends="e2fsprogs-dev"
+checkdepends="e2fsprogs"
 subpackages="$pkgname-doc"
-source="https://github.com/e2tools/e2tools/releases/download/$pkgver/e2tools-$pkgver.tar.gz
-	e2cp.1
-	e2ln.1
-	e2ls.1
-	e2mkdir.1
-	e2mv.1
-	e2rm.1
-	e2tail.1
-	e2tools.7
-	"
+source="https://github.com/e2tools/e2tools/releases/download/v$pkgver/e2tools-$pkgver.tar.gz"
 
 build() {
 	./configure \
@@ -34,20 +26,6 @@ check() {
 
 package() {
 	make DESTDIR="$pkgdir" install
-	install -dm 0755 "$pkgdir"/usr/share/man/man1
-	install -dm 0755 "$pkgdir"/usr/share/man/man7
-	install -pm 0644 "$srcdir"/e2tools.7 "$pkgdir"/usr/share/man/man7
-	for man in e2cp.1 e2ln.1 e2ls.1 e2mkdir.1 e2mv.1 e2rm.1 e2tail.1; do
-		install -pm 0644 "$srcdir/$man" "$pkgdir"/usr/share/man/man1
-	done
 }
 
-sha512sums="8be79385c07027286951755a7ca0407215b517d4abba5546a0958fcb5e8feaffc993d35dd56bde39e14d397875941fc812c713db3d27247cd8e9ee7ed6a153b4  e2tools-0.0.16.tar.gz
-11c91db4c1997e528e00f928d75e7330424b432ecbf03ac5f84ccf9bebba590a36839de4db1020c8fdbc43994669bc8ca027ede266fff0932bcdba01da614ffd  e2cp.1
-3ac5f23671444b4c77a0f51c8bca5eb3f3c90b5210e6ccfc9a6d076fe84075d63c863810a2140364625069a9cdc2541bd47ad43d0d785e1b4f58de3b74996a2c  e2ln.1
-86f129044eab493ce4fd81d892468388c9eac20f318f3e11f396090d4bed93d9bfc5cda1d48a522ec619271fcaa7f154f63c40095da9e93ad8dd2e55e075e8ed  e2ls.1
-4fbec4742c5b3b4b78544b9a0b50834b79ea08872eebaa81b41220c0d57c05891289684dff36faf6114235f78874d5d7f075a716aa8c72760b307782be01481d  e2mkdir.1
-2a4f3d1c6cb7dda083e1934523f0ec27200deb53b43359e5d366bedc0e15dd4f0f9cf9ad993089aa34c30a30810aab51ffc204181451055cf3d2050b774e544b  e2mv.1
-c2c85abe3360a202edb0bdde762e177eb1aec9a9775ae56716a3d45abbb2107e9cadebd73519932eaab413a054d870aaf547cc4ee1cf8595cd87666b050f3a41  e2rm.1
-f2f1535e23eff2d6238b9c7c47aca9691b2f55e70f91552c88877b49d02abaae6bff95eb034d954f4977cf04c49bc23a4cf0a8f693356b54d013e8ed6f367a0d  e2tail.1
-68303012608439ba0db2e6e09ed163c0b291ccd90f7615122fd99847d795f241d6a3fd40da97d31c1016ee4f11458c2e7c415c7348397cadbb519c7e49654938  e2tools.7"
+sha512sums="5fde992727946d253acd46987944bdf49615d2ab45bbea715c86b304d117c6900dd70fcffb093f3d564247e27978b78b4710e7fea7ffd28375e804955fe4d5c9  e2tools-0.1.0.tar.gz"
diff --git a/community/e2tools/e2cp.1 b/community/e2tools/e2cp.1
deleted file mode 100644
index 1842c9c35a85e32c6d14a241311b9af8e1ce8c07..0000000000000000000000000000000000000000
--- a/community/e2tools/e2cp.1
+++ /dev/null
@@ -1,61 +0,0 @@
-.TH E2CP 1 "March 2, 2005"
-.\"
-.SH NAME
-e2cp \- copies files from/to an e2fs filesystem
-.\"
-.SH SYNOPSIS
-.B e2cp
-.RI [ options ] " files... dest"
-.\"
-.SH DESCRIPTION
-The \fBe2cp\fP command copies files to/from an e2fs filesystem from/to the
-machine's filesystem.
-.\"
-.SH OPTIONS
-A single `-' (dash) can be used instead of a file name to indicate standard
-input/output.
-.TP
-.B \-0
-Input lines terminated by a null character.
-.TP
-.B \-a
-Absolute directory names - create directories instead of just copying
-into the destination. Only valid for copying into an ext2fs filesystem.
-.TP
-.B \-d \fIdest_dir\fP
-Destination of files to be copied. May be in the ext2fs filesystem or
-the host filesystem.
-.TP
-.B \-G \fIgid\fP
-Set the default group to gid.
-.TP
-.B \-O \fIuid\fP
-Set the default file owner to uid.
-.TP
-.B \-p
-Preserve host file attributes (permissions, times, etc.) when copying
-files.
-.TP
-.B \-P \fImode\fP
-Set the file permissions (ie 755, 666).
-.TP
-.B \-s \fIsrc_dir\fP
-The source of the files to be copied.
-.TP
-.B \-v
-Be verbose.
-.\"
-.SH SEE ALSO
-.BR e2tools (7),
-.BR e2ln (1),
-.BR e2ls (1),
-.BR e2mkdir (1),
-.BR e2mv (1),
-.BR e2rm (1),
-.BR e2tail (1).
-.\"
-.SH AUTHOR
-The \fBe2tools\fP were written by Keith Sheffield <sheff@pobox.com>.
-.PP
-This manual page was written by Lucas Wall <lwall@debian.org>,
-for the Debian project (but may be used by others).
diff --git a/community/e2tools/e2ln.1 b/community/e2tools/e2ln.1
deleted file mode 100644
index 8755c7c3c22121ec966e00b06003cafe27265f38..0000000000000000000000000000000000000000
--- a/community/e2tools/e2ln.1
+++ /dev/null
@@ -1,39 +0,0 @@
-.TH E2LN 1 "March 2, 2005"
-.\"
-.SH NAME
-e2ln \- create hard links on an ext2 filesystem
-.\"
-.SH SYNOPSIS
-.B e2ln
-.RI [ options ] " source destination"
-.\"
-.SH DESCRIPTION
-The \fBe2ln\fP command is used to create hard links on an ext2 filesystem.
-.\"
-.SH OPTIONS
-.TP
-.B \-f
-Force the operation to remove any existing files.
-.TP
-.B \-s
-Create a symlink.
-.TP
-.B \-v
-Be verbose.
-.PP
-Note: creating symlinks is not operational at this time.
-.\"
-.SH SEE ALSO
-.BR e2tools (7),
-.BR e2mv (1),
-.BR e2ls (1),
-.BR e2mkdir (1),
-.BR e2cp (1),
-.BR e2rm (1),
-.BR e2tail (1).
-.\"
-.SH AUTHOR
-The \fBe2tools\fP were written by Keith Sheffield <sheff@pobox.com>.
-.PP
-This manual page was written by Lucas Wall <lwall@debian.org>,
-for the Debian project (but may be used by others).
diff --git a/community/e2tools/e2ls.1 b/community/e2tools/e2ls.1
deleted file mode 100644
index cc763f92020c407bcf48864871e6363359fad2b7..0000000000000000000000000000000000000000
--- a/community/e2tools/e2ls.1
+++ /dev/null
@@ -1,59 +0,0 @@
-.TH E2LS 1 "March 2, 2005"
-.\"
-.SH NAME
-e2ls \- list files and directories on an ext2 filesystem
-.\"
-.SH SYNOPSIS
-.B e2ls
-.RI [ options ] " file_specification"
-.\"
-.SH DESCRIPTION
-The \fBe2ls\fP command is used to list files and directories on an ext2
-filesystem.
-.PP
-Note: Files deleted via e2rm sometimes will show up even without the -D
-option. It is being investigated.
-.\"
-.SH OPTIONS
-.TP
-.B \-a
-Show hidden directories.
-.TP
-.B \-c
-Sort by creation time (must include -t when using -l).
-.TP
-.B \-d \fIdir\fP
-Open the ext2 filesystem specified by dir.
-.TP
-.B \-D
-Show deleted files bracketed with ><.
-.TP
-.B \-f
-No sorting of the file list.
-.TP
-.B \-i
-Show the inodes (very useful for the -l option).
-.TP
-.B \-l
-Long listing.
-.TP
-.B \-r
-Reverse the sort order.
-.TP
-.B \-t
-Sort by time.
-.\"
-.SH SEE ALSO
-.BR e2tools (7),
-.BR e2ln (1),
-.BR e2mv (1),
-.BR e2mkdir (1),
-.BR e2cp (1),
-.BR e2rm (1),
-.BR e2tail (1).
-.\"
-.SH AUTHOR
-The \fBe2tools\fP were written by Keith Sheffield <sheff@pobox.com>.
-.PP
-This manual page was written by Lucas Wall <lwall@debian.org>,
-for the Debian project (but may be used by others).
diff --git a/community/e2tools/e2mkdir.1 b/community/e2tools/e2mkdir.1
deleted file mode 100644
index 1c230ec3bc26a0d66f4df27a45c0ee48a22d4e39..0000000000000000000000000000000000000000
--- a/community/e2tools/e2mkdir.1
+++ /dev/null
@@ -1,41 +0,0 @@
-.TH E2MKDIR 1 "March 2, 2005"
-.\"
-.SH NAME
-e2mkdir \- creates a directory on an ext2 filesystem
-.\"
-.SH SYNOPSIS
-.B e2mkdir
-.RI [ options ] " directory..."
-.\"
-.SH DESCRIPTION
-The \fBe2mkdir\fP command creates directories on an ext2 filesystem. It
-behaves similar to `mkdir -p'.
-.\"
-.SH OPTIONS
-.TP
-.B \-G \fIgid\fP
-Set the default group to gid.
-.TP
-.B \-O \fIuid\fP
-Set the default file owner to uid.
-.TP
-.B \-P \fImode\fP
-Set the file permissions (ie 755, 666).
-.TP
-.B \-v
-Be verbose.
-.\"
-.SH SEE ALSO
-.BR e2tools (7),
-.BR e2ln (1),
-.BR e2ls (1),
-.BR e2mv (1),
-.BR e2cp (1),
-.BR e2rm (1),
-.BR e2tail (1).
-.\"
-.SH AUTHOR
-The \fBe2tools\fP were written by Keith Sheffield <sheff@pobox.com>.
-.PP
-This manual page was written by Lucas Wall <lwall@debian.org>,
-for the Debian project (but may be used by others).
diff --git a/community/e2tools/e2mv.1 b/community/e2tools/e2mv.1
deleted file mode 100644
index 604226679c8feb30fa9b0704526f0d7ae09eb790..0000000000000000000000000000000000000000
--- a/community/e2tools/e2mv.1
+++ /dev/null
@@ -1,39 +0,0 @@
-.TH E2MV 1 "March 2, 2005"
-.\"
-.SH NAME
-e2mv \- moves or renames files on an ext2fs filesystem
-.\"
-.SH SYNOPSIS
-.B e2mv
-.RI [ options ] " files... dest"
-.\"
-.SH DESCRIPTION
-The \fBe2mv\fP command moves or renames files on an ext2fs filesystem. The
-source files must be explicitly stated. It does not use regular expressions,
-yet.
-.\"
-.SH OPTIONS
-.TP
-.B \-f
-Force the operation to remove any existing files.
-.TP
-.B \-s
-Swap names of the two files.
-.TP
-.B \-v
-Be verbose.
-.\"
-.SH SEE ALSO
-.BR e2tools (7),
-.BR e2ln (1),
-.BR e2ls (1),
-.BR e2mkdir (1),
-.BR e2cp (1),
-.BR e2rm (1),
-.BR e2tail (1).
-.\"
-.SH AUTHOR
-The \fBe2tools\fP were written by Keith Sheffield <sheff@pobox.com>.
-.PP
-This manual page was written by Lucas Wall <lwall@debian.org>,
-for the Debian project (but may be used by others).
diff --git a/community/e2tools/e2rm.1 b/community/e2tools/e2rm.1
deleted file mode 100644
index 1a6417283e92a0eb5110ce984fc78b2a9b0a8d78..0000000000000000000000000000000000000000
--- a/community/e2tools/e2rm.1
+++ /dev/null
@@ -1,34 +0,0 @@
-.TH E2RM 1 "March 2, 2005"
-.\"
-.SH NAME
-e2rm \- removes files and directories on an ext2 filesystem
-.\"
-.SH SYNOPSIS
-.B e2rm
-.RI [ options ] " files..."
-.\"
-.SH DESCRIPTION
-The \fBe2rm\fP command removes files and directories on an ext2 filesystem.
-.\"
-.SH OPTIONS
-.TP
-.B \-r
-Recursively delete files if a directory name is given.
-.TP
-.B \-v
-Be verbose.
-.\"
-.SH SEE ALSO
-.BR e2tools (7),
-.BR e2ln (1),
-.BR e2ls (1),
-.BR e2mkdir (1),
-.BR e2cp (1),
-.BR e2mv (1),
-.BR e2tail (1).
-.\"
-.SH AUTHOR
-The \fBe2tools\fP were written by Keith Sheffield <sheff@pobox.com>.
-.PP
-This manual page was written by Lucas Wall <lwall@debian.org>,
-for the Debian project (but may be used by others).
diff --git a/community/e2tools/e2tail.1 b/community/e2tools/e2tail.1
deleted file mode 100644
index bd48600fd4e2ad05b62b810d9057b8f164afcb11..0000000000000000000000000000000000000000
--- a/community/e2tools/e2tail.1
+++ /dev/null
@@ -1,46 +0,0 @@
-.TH E2TAIL 1 "March 2, 2005"
-.\"
-.SH NAME
-e2tail \- a basic version of the tail command for an ext2 filesystem
-.\"
-.SH SYNOPSIS
-.B e2tail
-.RI [ options ] " file"
-.\"
-.SH DESCRIPTION
-The \fBe2tail\fP command implements a basic version of the tail command.
-.\"
-.SH OPTIONS
-.TP
-.B \-n \fInum_lines\fP
-The number of lines to display
-.TP
-.B \-f
-Output appended data as the file grows.  This is inode dependent, so if the
-file is renamed, it will keep checking it.
-.TP
-.B \-F
-Output appended data as the file grows.  This is file name dependent, so if
-the file is renamed, it will check on any new files with the same name as the
-original.  This is useful for watching log files that may be rotated out
-occasionally.  This was requested by a person in the computer security field
-for monitoring 'honeypot' type machines.
-.TP
-.B \-s \fIsleep_interval\fP
-The number of seconds to sleep before checking if the file has grown while
-in 'follow' mode.  The default is 1.
-.\"
-.SH SEE ALSO
-.BR e2tools (7),
-.BR e2ln (1),
-.BR e2ls (1),
-.BR e2mkdir (1),
-.BR e2cp (1),
-.BR e2rm (1),
-.BR e2mv (1).
-.\"
-.SH AUTHOR
-The \fBe2tools\fP were written by Keith Sheffield <sheff@pobox.com>.
-.PP
-This manual page was written by Lucas Wall <lwall@debian.org>,
-for the Debian project (but may be used by others).
diff --git a/community/e2tools/e2tools.7 b/community/e2tools/e2tools.7
deleted file mode 100644
index c4bb9f512450f60240ca98e519f14190a95d4b71..0000000000000000000000000000000000000000
--- a/community/e2tools/e2tools.7
+++ /dev/null
@@ -1,72 +0,0 @@
-.TH E2TOOLS 7 "March 2, 2005"
-.\"
-.SH NAME
-e2tools \-  utilities to manipulate files in an ext2/ext3 filesystem
-.\"
-.SH DESCRIPTION
-E2tools is a simple set of GPL'ed utilities to read, write, and
-manipulate files in an ext2/ext3 filesystem. These utilities access a
-filesystem directly using the ext2fs library. I wrote these tools in order
-to copy files into a linux filesystem on a machine that does not have ext2
-support. Of course, they can also be used on a linux machine to read/write
-to disk images or floppies without having to mount them or have root
-access.
-.PP
-Supported functionality:
-.TP
-.B e2cp
-copy files
-.TP
-.B e2mv
-move files
-.TP
-.B e2rm
-remove files
-.TP
-.B e2mkdir
-create directory
-.TP
-.B e2ln
-create hard links
-.TP
-.B e2ls
-list files/directories
-.TP
-.B e2tail
-output the last part of a file
-.PP
-In general, to specify a directory or file on an ext2 filesystem for the
-e2tools utilities, use the following form:
-.IP
-filesystem:directory_path
-.PP
-The filesystem can be an unmounted partition or a regular file that's been
-formatted to contain an ext2 filesystem.  In general, if a command takes
-multiple file names on the command line, if the first one contains an ext2
-file specification, the rest of the files are assumed to be on the same
-filesystem until another one is explicitly stated:
-.IP
-/tmp/boot.img:/tmp/file1
-.IP
-/tmp/file2
-.IP
-/tmp/file3
-.IP
-/tmp/boot2.img:/tmp/file4
-.PP
-Files 1-3 are on /tmp/boot.img and the last file is on /tmp/boot2.img
-.\"
-.SH SEE ALSO
-.BR e2cp (1),
-.BR e2ln (1),
-.BR e2ls (1),
-.BR e2mkdir (1),
-.BR e2mv (1),
-.BR e2rm (1),
-.BR e2tail (1).
-.\"
-.SH AUTHOR
-The \fBe2tools\fP were written by Keith Sheffield <sheff@pobox.com>.
-.PP
-This manual page was written by Lucas Wall <lwall@debian.org>,
-for the Debian project (but may be used by others).