diff --git a/main/multipath-tools/APKBUILD b/main/multipath-tools/APKBUILD
index e464bb9d365ee1b33cc7c6dd0be1cbcbe76a383c..84b4e2cce721cb9af81e6a1ad417ccde29cbf5b4 100644
--- a/main/multipath-tools/APKBUILD
+++ b/main/multipath-tools/APKBUILD
@@ -1,11 +1,11 @@
 # Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
 pkgname=multipath-tools
 pkgver=0.8.3
-pkgrel=0
+pkgrel=1
 pkgdesc="Device Mapper Multipathing Driver"
 url="http://christophe.varoqui.free.fr"
 arch="all"
-license="GPL"
+license="GPL-2.0-only"
 depends="eudev"
 makedepends="lvm2-dev libaio-dev readline-dev ncurses-dev eudev-dev
 	userspace-rcu-dev json-c-dev perl"
@@ -14,7 +14,6 @@ source="$pkgname-$pkgver.tar.gz::https://git.opensvc.com/gitweb.cgi?p=$pkgname/.
 	multipath-tools.conf
 	multipath-tools.confd
 	multipath-tools.initd
-	fix-unknown-mode_t.patch
 	"
 options="!check"
 builddir="$srcdir/multipath-tools"
@@ -48,5 +47,4 @@ package() {
 sha512sums="d9fdc2763f5a1efa15ee07c5d863008c9694623935f62a0e0b56f941df4e0d0ca3f86056fefc9b5ca828b47782127e3d55f2f925b1ed957e02b675bef36f4cae  multipath-tools-0.8.3.tar.gz
 e81462b22c0cbc92ea935d7544b9f9a0c4ccbcf13f3bc03dadf6de96407c9cf49964c9bbf02f12a134e1255c66421c6fde39d54b15eef975e8df81bdc88b2213  multipath-tools.conf
 303c62b7506b207ba2266310e7a701d76151e6f1544b44faf666dfabdc59c5aeb98544d380988e18b4a7b8235e4000380f025c4dd6c95d45a7b8b51bbf39dce5  multipath-tools.confd
-1ca0a8be7ddd0d57b810ab4905bc35d6b89b924ef528a7ee77dad162b86b990e0b86ef714f63857def4a61e30bfabe7a3980f624d63b80108408dd876a7c468c  multipath-tools.initd
-079943d788d4ecf250a201f38cca4661c29499dd1ba9b74b471c66fe59785215fd096425d51e74664e5e68a21378179b081bc8d9503c7ed99bc3d7f785ecf8cd  fix-unknown-mode_t.patch"
+1ca0a8be7ddd0d57b810ab4905bc35d6b89b924ef528a7ee77dad162b86b990e0b86ef714f63857def4a61e30bfabe7a3980f624d63b80108408dd876a7c468c  multipath-tools.initd"
diff --git a/main/multipath-tools/fix-unknown-mode_t.patch b/main/multipath-tools/fix-unknown-mode_t.patch
deleted file mode 100644
index e5f980e3f67b59ae1f83e4fa3269fda3d00bbbc2..0000000000000000000000000000000000000000
--- a/main/multipath-tools/fix-unknown-mode_t.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Fixes the following error:
-
-    In file included from alias.c:15:0:
-    file.h:9:47: error: unknown type name 'mode_t'
-     int ensure_directories_exist(const char *str, mode_t dir_mode);
-                                                   ^~~~~~
-    make[1]: *** [../Makefile.inc:134: alias.o] Error 1
-
---- a/libmultipath/alias.c
-+++ b/libmultipath/alias.c
-@@ -8,6 +8,7 @@
- #include <string.h>
- #include <limits.h>
- #include <stdio.h>
-+#include <sys/stat.h>
- 
- #include "debug.h"
- #include "uxsock.h"