diff --git a/community/alpine/APKBUILD b/community/alpine/APKBUILD
index c9c23a332244cefa36d6713bbc374e2b483c46a3..a16a849f66cb749ba86fb8655531b8858ed2c765 100644
--- a/community/alpine/APKBUILD
+++ b/community/alpine/APKBUILD
@@ -3,36 +3,26 @@ pkgname=alpine
 pkgver=2.21
 _ver=${pkgver%_p*}
 _pver=${pkgver##*_p}
-pkgrel=3
+pkgrel=4
 pkgdesc="Text-based email client, friendly for novices but powerful"
-url="http://www.washington.edu/alpine/"
+url="http://alpine.x10host.com/alpine/"
 arch="all"
 license="Apache-2.0"
-depends=""
 makedepends="openldap-dev heimdal-dev ncurses-dev openssl-dev
-	automake autoconf libtool"
+	automake autoconf libtool gettext-dev"
 subpackages="$pkgname-doc"
 source="http://alpine.x10host.com/alpine/release/src/alpine-$pkgver.tar.xz
 	uclibc-musl.patch
 	"
 
-_builddir="$srcdir"/$pkgname-$_ver
+builddir="$srcdir"/$pkgname-$_ver
+
 prepare() {
-	cd "$_builddir"
-	for i in $source; do
-		case $i in
-		*.patch)
-			msg "Applying $i"
-			patch -p1 -i "$srcdir"/$i || return 1
-			;;
-		esac
-	done
-	libtoolize --force && aclocal -I m4 && autoconf \
-		&& automake --force --add-missing || return 1
+	default_prepare
+	autoreconf -fi
 }
 
 build() {
-	cd "$_builddir"
 	./configure \
 		--build=$CBUILD \
 		--host=$CHOST \
@@ -41,14 +31,12 @@ build() {
 		--without-tcl \
 		--disable-shared \
 		--with-system-pinerc=/etc/alpine.d/pine.conf \
-		--with-system-fixed-pinerc=/etc/alpine.d/pine.conf.fixed \
-		|| return 1
+		--with-system-fixed-pinerc=/etc/alpine.d/pine.conf.fixed
 	make
 }
 
 package() {
-	cd "$_builddir"
-	make DESTDIR="$pkgdir" install || return 1
+	make DESTDIR="$pkgdir" install
 }
 
 sha512sums="a2a36a033c8af79810816a7da7185c269808ba6d84d013691fd8b3764c63f5fb2284e6844ec5a5e99d168514ae636debf59fae962533a2916679e4e9109c6264  alpine-2.21.tar.xz