main/strace: patch updated IPPROTO_MAX

musl has [updated][0] the value of `IPPROTO_MAX` to include new
protocols. Strace keeps a copy of these constants and verifies them at
build time.

This results in a build failure:

```
xlat/inet_protocols.h:239:1: error: static assertion failed:
"IPPROTO_MAX != 256"
  239 | static_assert((IPPROTO_MAX) == (256), "IPPROTO_MAX != 256");
        | ^~~~~~~~~~~~~
```

Update the value of `IPPROTO_MAX` to match what's in
`/usr/include/inet/in.h`

Fixes #12132

[0]:https://git.musl-libc.org/cgit/musl/commit/?h=8fca0ea4e9d09b0ada66b135533a74a643de77ef
7 jobs for !14903 with strace-fix-max-proto in 2 minutes and 54 seconds
detached
Status Job ID Name Coverage
  Lint
passed #253730
docker-alpine x86_64
lint

00:00:25

 
  Build
passed #253735
docker-alpine ci-build aarch64
build-aarch64

00:01:58

passed #253736
docker-alpine ci-build armv7
build-armv7

00:02:26

passed #253734
docker-alpine ci-build ppc64le
build-ppc64le

00:02:11

passed #253733
docker-alpine ci-build s390x
build-s390x

00:02:06

passed #253732
docker-alpine ci-build x86
build-x86

00:01:20

passed #253731
docker-alpine ci-build x86_64
build-x86_64

00:01:31