community/zabbix: upgrade to 5.0.0

Zabbix agent does no longer build against gnutls, so switch to openssl.
7 jobs for !7833 with zabbix-5.0.0 in 5 minutes and 41 seconds
merge request