Commit e2474149 authored by Kevin Daudt's avatar Kevin Daudt 💻

main/bind: depend on bind-tools

The install script needs to call rndc-confgen to generate a key which is
required for reloading to work.

955e3791 (main/bind: add support for "reload", 2019-10-19) added
support for reload, but that causes an issues when installing bind,
because rndc-confgen is in the bind-tools subpackage, which is not
available if you just install bind.

Fix this by having bind depend on bind-tools.

Fixes #10935
parent d4a83645
Pipeline #1981 passed with stages
in 8 minutes and 24 seconds
...@@ -10,14 +10,14 @@ _ver=${pkgver%_p*} ...@@ -10,14 +10,14 @@ _ver=${pkgver%_p*}
_p=${pkgver#*_p} _p=${pkgver#*_p}
_major=${pkgver%%.*} _major=${pkgver%%.*}
[ "$_p" != "$pkgver" ] && _ver="${_ver}-P$_p" [ "$_p" != "$pkgver" ] && _ver="${_ver}-P$_p"
pkgrel=3 pkgrel=4
pkgdesc="The ISC DNS server" pkgdesc="The ISC DNS server"
url="https://www.isc.org" url="https://www.isc.org"
arch="all" arch="all"
license="MPL-2.0" license="MPL-2.0"
pkgusers="named" pkgusers="named"
pkggroups="named" pkggroups="named"
depends="dns-root-hints" depends="dns-root-hints bind-tools"
depends_dev="$pkgname $pkgname-plugins $pkgname-tools" depends_dev="$pkgname $pkgname-plugins $pkgname-tools"
depends_libs="" depends_libs=""
depends_plugins="$pkgname" depends_plugins="$pkgname"
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment