testing/profanity: disable plugins support

Most of the plugins are in Python, and none of them looks
critical nor useful: https://github.com/profanity-im/profanity-plugins/tree/master/stable
Having python plugin support means dragging Python3 as a dependency.
7 jobs for !19376 with profanity_plugins in 30 seconds (queued for 1 second)
merge request