Commit be554563 authored by Leo's avatar Leo
Browse files

testing/kafkacat: upgrade to 1.5.0

parent cd5bfc93
# Contributor: Andrey Pustovetov <andrey.pustovetov@gmail.com>
# Maintainer: Andrey Pustovetov <andrey.pustovetov@gmail.com>
pkgname=kafkacat
pkgver=1.4.0
pkgver=1.5.0
pkgrel=0
pkgdesc="Generic command-line non-JVM Apache Kafka producer and consumer"
url="https://github.com/edenhill/kafkacat"
......@@ -11,10 +11,8 @@ license="BSD-2-Clause"
options="!check" # upstream doesn't have a test suite
makedepends="bash yajl-dev librdkafka-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/edenhill/kafkacat/archive/$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
./configure \
--prefix=/usr \
--mandir=/usr/share/man \
......@@ -23,8 +21,7 @@ build() {
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
sha512sums="c4607ae16b693fa60ba51dec3ecd527197de56d91c7a2a6397d9f56af6db41bee9bf702943fb56f4ce7d6b996cd7eb7d86881b8a5002f3b450fa6f7485854690 kafkacat-1.4.0.tar.gz"
sha512sums="57f75b26ef32df244043fa9fc17dc2d6fd93daeea4bc389aa78356ea6e45dea780ff9c3462ed27d2a7798560a21eef04f098bf7766c7305bcee4573f557651ad kafkacat-1.5.0.tar.gz"
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment