testing/newlib-stage1: fix depends and license

Let the newlib-stage1 meta-package depend on newlib-*-stage1, not
newlib-*.
parent c960fda8
...@@ -11,12 +11,12 @@ case "$CARCH" in ...@@ -11,12 +11,12 @@ case "$CARCH" in
esac esac
pkgname=newlib-stage1 pkgname=newlib-stage1
pkgver=3.3.0 pkgver=3.3.0
pkgrel=0 pkgrel=1
pkgdesc="A C standard library implementation intended for use on embedded systems" pkgdesc="A C standard library implementation intended for use on embedded systems"
url="http://www.sourceware.org/newlib/" url="http://www.sourceware.org/newlib/"
makedepends="texinfo" makedepends="texinfo"
arch="all" arch="all"
license="BSD" license="GPL-2.0-only AND LGPL-2.1-only AND 0BSD AND BSD-3-Clause AND GPL-3.0-only AND LGPL-3.0-only"
source="ftp://sourceware.org/pub/newlib/newlib-$pkgver.tar.gz" source="ftp://sourceware.org/pub/newlib/newlib-$pkgver.tar.gz"
options="!check" options="!check"
...@@ -102,7 +102,7 @@ build() { ...@@ -102,7 +102,7 @@ build() {
package() { package() {
for target in $_targets; do for target in $_targets; do
depends="$depends newlib-$target" depends="$depends newlib-$target-stage1"
done done
mkdir -p "$pkgdir" mkdir -p "$pkgdir"
} }
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment