Commit 35dc5dbd authored by Bart Ribbers's avatar Bart Ribbers Committed by Leo

community/krita: upgrade to 4.3.0

parent ae4c42f5
# Contributor: Bart Ribbers <bribbers@disroot.org> # Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org> # Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=krita pkgname=krita
pkgver=4.2.9 pkgver=4.3.0
pkgrel=4 pkgrel=0
arch="all !aarch64 !armv7 !armhf !mips !mips64" # Blocked by py3-qt5 -> qt5-qtdeclarative, OpenGLES arch="all !aarch64 !armv7 !armhf !mips !mips64" # Blocked by py3-qt5 -> qt5-qtdeclarative, OpenGLES
url="https://krita.org/" url="https://krita.org/"
pkgdesc="Free digital painting application. Digital Painting, Creative Freedom!" pkgdesc="Free digital painting application. Digital Painting, Creative Freedom!"
license="GPL-2.0-or-later" license="GPL-2.0-or-later"
makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtsvg-dev qt5-qtmultimedia-dev qt5-qttools-dev kconfig-dev kwidgetsaddons-dev kcompletion-dev kcoreaddons-dev kguiaddons-dev ki18n-dev kitemmodels-dev kitemviews-dev kwindowsystem-dev karchive-dev kcrash-dev libxi-dev boost-dev libraw-dev fftw-dev eigen-dev exiv2-dev lcms2-dev quazip-dev gsl-dev zlib-dev openexr-dev tiff-dev libjpeg-turbo-dev giflib-dev libheif-dev python3-dev py3-qt5 poppler-qt5-dev xcb-util-dev" makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtsvg-dev qt5-qtmultimedia-dev qt5-qttools-dev kconfig-dev kwidgetsaddons-dev kcompletion-dev kcoreaddons-dev kguiaddons-dev ki18n-dev kitemmodels-dev kitemviews-dev kwindowsystem-dev karchive-dev kcrash-dev libxi-dev boost-dev libraw-dev fftw-dev eigen-dev exiv2-dev lcms2-dev quazip-dev gsl-dev zlib-dev openexr-dev tiff-dev libjpeg-turbo-dev giflib-dev libheif-dev python3-dev py3-qt5 poppler-qt5-dev xcb-util-dev"
checkdepends="xvfb-run" checkdepends="xvfb-run"
source="https://download.kde.org/stable/krita/$pkgver/krita-$pkgver.tar.xz source="https://download.kde.org/stable/krita/$pkgver/krita-$pkgver.tar.xz"
fix-crash-with-c-locale.patch
"
subpackages="$pkgname-lang" subpackages="$pkgname-lang"
options="!check" # Breaks compilation on Musl https://bugs.kde.org/show_bug.cgi?id=412058 options="!check" # Breaks compilation on Musl https://bugs.kde.org/show_bug.cgi?id=412058
...@@ -22,7 +20,7 @@ build() { ...@@ -22,7 +20,7 @@ build() {
-DCMAKE_INSTALL_LIBDIR=lib \ -DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_KRITA_QT_DESIGNER_PLUGINS=ON \ -DBUILD_KRITA_QT_DESIGNER_PLUGINS=ON \
-DBUILD_TESTING=OFF -DBUILD_TESTING=OFF
make -C build cmake --build build
} }
check() { check() {
...@@ -31,8 +29,7 @@ check() { ...@@ -31,8 +29,7 @@ check() {
} }
package() { package() {
DESTDIR="$pkgdir" make -C build install DESTDIR="$pkgdir" cmake --build build --target install
} }
sha512sums="66eef3d1b5647e62551276662ef4332f15abc022f1032f27a2ad695a8d2dc5fa758146492a9da2b8cbd4a52e47c576473029d2aa9728dea3bec869b8173f08c0 krita-4.2.9.tar.xz sha512sums="5633a6ccacc140b119082f14fe792b1219b8065304fccc55a84a2373a46cb036ad40f718beb8719e1f664e35d679b18e86f5f3db8685166a187d8cf3a77722f4 krita-4.3.0.tar.xz"
e7a9117d012df4181e05de970f2210264b8685ee76c98b33795f8095d9a17b24b20e6ce920f944b4b5cb940cf672af5ba5fd0ffae9f53085a4f97da61b1e69f6 fix-crash-with-c-locale.patch"
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment