diff --git a/main/mesa/APKBUILD b/main/mesa/APKBUILD
index 914f3e4349f13cb2e40f067a6782f6f18e9c9f46..564d963a293f914e7e00e904125963db0fe12579 100644
--- a/main/mesa/APKBUILD
+++ b/main/mesa/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=mesa
 pkgver=24.3.2
-pkgrel=0
+pkgrel=1
 pkgdesc="Mesa DRI OpenGL library"
 url="https://www.mesa3d.org"
 arch="all"
@@ -405,5 +405,5 @@ _vulkan_layers() {
 sha512sums="
 ea1065f7b466f1b2b3570c87585d6de15e3784a60d920c9f991c22720197d5947b598ac2c76773bed8150c91360ee5bbc77f3b48780a19502a8c4224baa728b9  mesa-24.3.2.tar.xz
 f4d6589f632ef4306fac031b4832953a6e8855341999a2366696b25bbdc2619bd068711e4ca3825c219a7dd6b1bd3837f5127daaff363b390098824f7988631a  245e063ee74b88479bd69246ba07bdfd52985ebd.patch
-c151f9fb3d4d2e49fcdbbea492c7c1946148333c74a7356abce33594487b2ed512434673e8dcc279219d7ad068bd04c8cc329fa6f2e897e6311441fe65e061db  riscv64-tls.patch
+ce1887fb7d425b94c375a0547bee40c308809c01f5ce1bcddabcc69a7fcb445efb9d5f5c7bac49b2778ab40687c7bce204d278b0bf028d124c75e59083107fba  riscv64-tls.patch
 "
diff --git a/main/mesa/riscv64-tls.patch b/main/mesa/riscv64-tls.patch
index 244f436a27a884a39a4e9f4b3bf52f35c91233bf..55932a3f4581699aea672727146d5a7abf726b74 100644
--- a/main/mesa/riscv64-tls.patch
+++ b/main/mesa/riscv64-tls.patch
@@ -1,7 +1,5 @@
 upstream: https://gitlab.freedesktop.org/mesa/mesa/-/issues/11729
 
-also loongarch64 needs to use -mtls-dialect=trad
-
 diff --git a/meson.build b/meson.build
 index 3d72bb56f25..5161c97af11 100644
 --- a/meson.build
@@ -11,7 +9,7 @@ index 3d72bb56f25..5161c97af11 100644
    endif
  endforeach
 -if not have_mtls_dialect
-+if not have_mtls_dialect and host_machine.cpu_family() != 'riscv64' and host_machine.cpu_family() != 'loongarch64'
++if not have_mtls_dialect and host_machine.cpu_family() != 'riscv64'
    # need .run to check libc support. meson aborts when calling .run when
    # cross-compiling, but because this is just an optimization we can skip it
    if meson.is_cross_build() and not meson.can_run_host_binaries()