Commit 17d11c81 authored by Will Sinatra's avatar Will Sinatra Committed by Leo

testing/networkmanager-l2tp: use strongswan instead of libreswan

libreswan currently cannot validate IKE, due to an assertion failure (see #11656).

A patch to the libreswan package is required to fix this, which is upstream of our
package, but not yet implemented in 3.32. Libreswan additionally does not support
3des-sha1-modp1024, which is needed for l2tp VPNs created by devices like the Cisco Meraki.

Strongswan has neither of these issues.
parent 0af183c0
Pipeline #48717 passed with stages
in 2 minutes and 40 seconds
......@@ -2,14 +2,14 @@
# Maintainer: Will Sinatra <wpsinatra@gmail.com>
pkgname=networkmanager-l2tp
pkgver=1.8.2
pkgrel=0
pkgrel=1
pkgdesc="L2TP support for NetworkManager"
url="https://github.com/nm-l2tp/NetworkManager-l2tp"
license="GPL-2.0-only"
arch="all"
makedepends="intltool python3 libnma-dev libtool automake autoconf gettext-dev
glib-dev ppp-dev nss-dev gtk+3.0-dev libsecret-dev openssl-dev"
depends="libnma ppp xl2tpd libsecret openssl nss libreswan gtk+3.0"
depends="libnma ppp xl2tpd libsecret openssl nss strongswan gtk+3.0"
source="$pkgname-$pkgver.tar.gz::https://github.com/nm-l2tp/NetworkManager-l2tp/archive/$pkgver.tar.gz"
options="!check" #no check
builddir="$srcdir/NetworkManager-l2tp-$pkgver"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment