Commit ace430a1 authored by Bart Ribbers's avatar Bart Ribbers
Browse files

community/py3-twine: upgrade to 3.4.1

parent b007f964
diff --git a/pyproject.toml b/pyproject.toml
index 21b5d29..1c79d15 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,5 +1,5 @@
[build-system]
-requires = ["setuptools>=40.8", "wheel", "setuptools_scm>=1.15"]
+requires = ["setuptools>=40.8", "wheel"]
build-backend = "setuptools.build_meta:__legacy__"
[tool.towncrier]
diff --git a/setup.cfg b/setup.cfg
index bcd7a09..4d8ab85 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -43,8 +43,6 @@ install_requires =
keyring >= 15.1
rfc3986 >= 1.4.0
colorama >= 0.4.3
-setup_requires =
- setuptools_scm >= 1.15
include_package_data = True
[options.entry_points]
diff --git a/setup.py b/setup.py
index e69bda6..7aab391 100644
--- a/setup.py
+++ b/setup.py
@@ -14,4 +14,4 @@
import setuptools
-setuptools.setup(use_scm_version=True)
+setuptools.setup(use_scm_version=False)
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-twine
pkgver=3.3.0
pkgver=3.4.1
pkgrel=0
pkgdesc="Collection of utilities for publishing packages on PyPI"
options="!check" # Requires unpackaged 'pretend'
......@@ -18,7 +18,9 @@ depends="python3
py3-keyring
"
checkdepends="py3-pytest"
source="https://files.pythonhosted.org/packages/source/t/twine/twine-$pkgver.tar.gz"
source="https://files.pythonhosted.org/packages/source/t/twine/twine-$pkgver.tar.gz
0001-remove-setuptools-scm.patch
"
builddir="$srcdir/twine-$pkgver"
build() {
......@@ -33,4 +35,5 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="e22f6eed0ecc17fc17d818d1d608bf8aef26fbd0c1645a131cbe313efc120cb5d88b548c8112980bbdcf46bd617e0902fdd0a1e45c578845126d9caf229fe68e twine-3.3.0.tar.gz"
sha512sums="16e06ce984aa2c5e875813c24c1fd4c0f7a3ccb39e6079d675a9e094eb23eba691dd766b675f5a9acb9ed57b6c92453dcba9707914550d73dbff50a1ec21371e twine-3.4.1.tar.gz
4b4fc104eb2311e049bc59976c97bf06b7e7cc47d07b19b8b70baa62629ac318d704a23dee011116a26cd302d71bc24e1e8885fcc8d93edf978b39e7de472168 0001-remove-setuptools-scm.patch"
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment