Commit c67cfbaa authored by Rasmus Thomsen's avatar Rasmus Thomsen Committed by Leo
Browse files

main/libsecret: upgrade to 0.20.2

parent d1124b2f
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=libsecret
pkgver=0.20.1
pkgrel=1
pkgver=0.20.2
pkgrel=0
pkgdesc="Library for storing and retrieving passwords and other secrets"
url="https://wiki.gnome.org/Projects/Libsecret"
arch="all"
license="LGPL-2.0-or-later"
makedepends="glib-dev intltool libxslt-dev docbook-xsl libgcrypt-dev
gobject-introspection-dev vala meson"
checkdepends="py3-dbus py3-gobject3 xvfb-run dbus-x11 gjs"
checkdepends="py3-dbus py3-gobject3 xvfb-run dbus-x11"
options="!check" # gjs is in community now
subpackages="$pkgname-static $pkgname-dev $pkgname-doc $pkgname-lang"
source="https://download.gnome.org/sources/libsecret/${pkgver%.*}/libsecret-$pkgver.tar.xz
support-static-lib.patch"
case "$CARCH" in
# Missing check dependency: gjs
s390x) options="$options !check" ;;
# All tests fail on 32bit
armhf|armv7|x86) options="$options !check" ;;
esac
source="https://download.gnome.org/sources/libsecret/${pkgver%.*}/libsecret-$pkgver.tar.xz"
build() {
meson \
......@@ -43,5 +36,4 @@ package() {
}
sha512sums="d8fca5f4da63427f594e1cb38c91330a98ab706aa945f8e735337f3fd342895bc96ceb36390ba01a4c0b9c5d503c4b544753c3243c444579f46f7b2e7836d1ac libsecret-0.20.1.tar.xz
63769061674fb0227c00975303699fa9c6685accb177ae738b601c58547eedfdaf78f4cbb152835dda6ccbb771004f361b402d88eff8e51fc3c8563b71180aeb support-static-lib.patch"
sha512sums="89143c8ccc8f6fa0cda2c98baef92e8cbf9b319a984826a09c527125e14712023ee65cada42a2c9232524528da8c1c3d2235ecbcb93e2f06e94121a601c22857 libsecret-0.20.2.tar.xz"
diff --git a/libsecret/meson.build b/libsecret/meson.build
index 09041ce..759b5ef 100644
--- a/libsecret/meson.build
+++ b/libsecret/meson.build
@@ -84,7 +84,7 @@ libsecret_cflags = [
'-DSECRET_COMPILATION',
]
-libsecret = shared_library('secret-@0@'.format(api_version_major),
+libsecret = library('secret-@0@'.format(api_version_major),
[ libsecret_sources, _dbus_generated, _enums_generated ],
version: libtool_version,
dependencies: libsecret_dependencies,
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment