Commit ae749e5c authored by Leo's avatar Leo
Browse files

main/openvpn: fix dev dependencies and modernize

- --enable-crypto is no longer a recognized option
- Remove unnecessary article from the pkgdesc
- make openssl-dev a dependency of the -dev subpackages as
  openvpn-plugin.h header includes openssl/x509.h
parent 57b6241c
......@@ -2,14 +2,15 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=openvpn
pkgver=2.5.0
pkgrel=0
pkgdesc="A robust, and highly configurable VPN (Virtual Private Network)"
pkgrel=1
pkgdesc="Robust, and highly configurable VPN (Virtual Private Network)"
url="https://openvpn.net/"
arch="all"
license="custom"
subpackages="$pkgname-doc $pkgname-dev $pkgname-openrc $pkgname-auth-pam:pam"
depends="iproute2"
makedepends="openssl-dev lzo-dev linux-pam-dev linux-headers"
depends_dev="openssl-dev" # openvpn-plugin.h includes openssl/x509.h
makedepends="$depends_dev lzo-dev linux-pam-dev linux-headers"
install="$pkgname.pre-install"
source="https://swupdate.openvpn.net/community/releases/openvpn-$pkgver.tar.xz
openvpn.initd
......@@ -31,7 +32,6 @@ build() {
--prefix=/usr \
--mandir=/usr/share/man \
--sysconfdir=/etc/openvpn \
--enable-crypto \
--enable-iproute2
make
}
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment